I'm trying to access a chatroom with my AIM account. I have Kubuntu 9.04 amd64

I tried using Pidgin but ran into the bug that logs you out after 5/10 minutes of being in the room:

((00:20:21) MY USERNAME left the room.
(00:20:21) You have been disconnected from chat room !aol://CHATROOM ADDRESS?

I used Kopete but it won't let me join. I found the AIM menu, clicked Join Chat... entered the room name and the exchange number which I know is right because it worked for those 5 minutes on Pidgin, (it's 4) and I click OK and nothing happened.

The window disappears and that's it. Kopete is still running. individual chats with people are still running, but no chatroom.

I'm using wireless and it sometimes disconnects/reconnects despite only being a room away from the router. I don't know, I read somewhere that possibly a dodgy internet connection has something to do with it? A wired connection is pretty much out of the question considering room sharing arrangements.

Any help much appreciated, I'm not very computer savvy so please over-simplify