install kmix, enable all channels, check capture, set 'input source' to Int Mic I have tried many mixer apps with my 6930 but kmix is the only one that provides the option. Hope this helps.