Here is a slightly strange but related question. My apologise that I start off talking about Windows but nobody is perfect!!


"OS: Windows 7 Home Premium OA

Start up and installation worked first round. I then made the following partitions:

C:Windows (original system partition)
D: Data (here I put all my working files)
F: Executables (here are all the binary executables that I use)

I moved some files from C:\Programs to F:\Programs.

Everything worked fine.

Then I got clever and decided to change F:Executables to E:Executables (E for Executables) to do this I had to move EVD (original system default) to a new letter. I chose OVD (O for 'Optical') and moved F: to E:.

Then I re-booted.

Now the system boots all the way to the login screen except that there are no user choices. Windows itself has obviously started because other functions such as the 'Shutdown' and 'Restart' buttons work. But no User icons or boxes appear to select a user and enter a password."

At this point I thought "DAMN and double BLAST!"

After a bit of cursing and thinking (these often work well together) I had the idea to see what my (up until this point unused UBUNTU boot disk could do. In it went to the optical drive and started up a dream. In fact I had access to all the WIndows partitions as well. However, I can't seem to get windows applications to run under UBUNTU yet (mostly because I haven't tried very hard).

I suspect that the problem with my Windows installation is that I need to fix some drive pointers in the windows registery file. Unfortunately the 'regedit' utility doesn't want to work directly under UBUNTO. When I double click on it in the file manager it complains that it must be some kind of corrupted *.zip file. Most unsatisfactory.

After this very long post the basic question is:

Can I open up and edit the windows registry file directly from UBUNTU?


Any other ideas?