Results 1 to 6 of 6

Thread: 9.10 broken upgrade, xulrunner?

  1. #1
    Join Date
    Jan 2010
    Beans
    2

    9.10 broken upgrade, xulrunner?

    I have been running Ubuntu 9.10 for some time, to keep my system current I recently did:
    apt-get update
    apt-get upgrade

    during the upgrade it failed to complete, NOW firefox will not work. nor can I get past the installation of xulrunner.

    I did a apt-get clean, apt-get update and tried to complete the upgrade only to be back where I started.

    here is the text of the failed upgrade:

    <snip..snip>

    root@raptor:/home/jeff# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    9 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up xulrunner-1.9.1 (1.9.1.7+nobinonly-0ubuntu0.9.10.1) ...
    /var/lib/dpkg/info/xulrunner-1.9.1.postinst: 5: /usr/bin/xulrunner-1.9.1: not found
    dpkg: error processing xulrunner-1.9.1 (--configure):
    subprocess installed post-installation script returned error exit status 127
    dpkg: dependency problems prevent configuration of firefox-3.5:
    firefox-3.5 depends on xulrunner-1.9.1 (>= 1.9.1); however:
    Package xulrunner-1.9.1 is not configured yet.
    dpkg: error processing firefox-3.5 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox-3.5-branding:
    firefox-3.5-branding depends on firefox-3.5 (= 3.5.7+nobinonly-0ubuntu0.9.10.1); however:
    Package firefox-3.5 is not configured yet.
    dpkg: error processing firefox-3.5-branding (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox:
    firefox depends on firefox-3.5; however:
    Package firefox-3.5 is not configured yet.
    firefox depends on firefox-3.5-branding; however:
    Package firNo apport report written because the error message indicates its a followup error from a previous failure.
    No apport report written because the error message indicates its a followup error from a previous failure.
    No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
    efox-3.5-branding is not configured yet.
    dpkg: error processing firefox (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox-3.0:
    firefox-3.0 depends on firefox-3.5; however:
    Package firefox-3.5 is not configured yet.
    dpkg: error processing firefox-3.0 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of xulrunner-1.9.1-gnome-support:
    xulrunner-1.9.1-gnome-support depends on xulrunner-1.9.1 (= 1.9.1.7+nobinonly-0ubuntu0.9.10.1); however:
    Package xulrunner-1.9.1 is not configured yet.
    dpkg: error processing xulrunner-1.9.1-gnome-support (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox-3.5-gnome-support:
    firefox-3.5-gnome-support depends on firefox-3.5 (= 3.5.7+nobinonly-0ubuntu0.9.10.1); however:
    Package firefox-3.5 is not configured yet.
    firefox-3.5-gnome-support depends on xulrunner-1.9.1-gnome-support; however:
    Package xulrunner-1.9.1-gnome-support is not configured yet.
    dpkg: error processing firefox-3.5-gnome-support (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox-3.0-gnome-support:
    firefox-3.0-gnome-support depends on firefox-3.5-gnome-support; however:
    Package firefox-3.5-gnome-support is not configured yet.
    dpkg: error processing firefox-3.0-gnome-support (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of firefox-gnome-support:
    firefox-gnome-support depends on firefox-3.5-gnome-support; however:
    Package firefox-3.5-gnome-support is not configured yet.
    dpkg: error processing firefox-gnome-support (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    xulrunner-1.9.1
    firefox-3.5
    firefox-3.5-branding
    firefox
    firefox-3.0
    xulrunner-1.9.1-gnome-support
    firefox-3.5-gnome-support
    firefox-3.0-gnome-support
    firefox-gnome-support
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    <snip..snip>

    Any ideas how to get this to work?

    Thanks.

  2. #2
    Join Date
    Mar 2006
    Beans
    8,345

    Re: 9.10 broken upgrade, xulrunner?

    Code:
    sudo dpkg --configure -a
    There is no greater religion than a truth.

  3. #3
    Soul-Sing is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Aug 2006
    Beans
    1,374
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: 9.10 broken upgrade, xulrunner?

    1)
    Code:
    sudo apt-get -f install
    to force an install of the files

    ----if this doesn't work

    2)
    Code:
    gksudo nautilus
    navigate to /var/lib/dpkg/info and deleting everything that has this name:
    xulrunner-1.9.1
    firefox-3.5
    firefox-3.5-branding
    firefox
    firefox-3.0
    xulrunner-1.9.1-gnome-support
    firefox-3.5-gnome-support
    firefox-3.0-gnome-support
    firefox-gnome-support
    using the "searchoption" rightabove.

    Code:
    sudo apt-get update
    Code:
    sudo apt-get upgrade
    should "give" you your updated firefox back

  4. #4
    Join Date
    Jan 2010
    Beans
    2

    Re: 9.10 broken upgrade, xulrunner?

    Thanks,

    That seemed to got me to install xulrunner and firefox but now I got another firefox problem.

    "Could not find compatible GRE version 1.9.1 and 1.9.1.*."

    I remember seeing somewhere in another thread with something to do with this,
    will try and search for that thread.

  5. #5
    Soul-Sing is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Aug 2006
    Beans
    1,374
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: 9.10 broken upgrade, xulrunner?

    Quote Originally Posted by thundercatHO View Post
    Thanks,

    That seemed to got me to install xulrunner and firefox but now I got another firefox problem.

    "Could not find compatible GRE version 1.9.1 and 1.9.1.*."

    I remember seeing somewhere in another thread with something to do with this,
    will try and search for that thread.
    I will give it try too, if you found the thread please let us know.
    it is definitly a xulrunner related problem, no doubt.

    : http://ubuntuforums.org/showthread.php?t=1343374
    : http://kubuntuforums.net/forums/inde...opic=3108915.0
    Last edited by Soul-Sing; January 12th, 2010 at 08:09 PM.

  6. #6
    Join Date
    Jul 2007
    Beans
    186

    Re: 9.10 broken upgrade, xulrunner?

    I used

    sudo apt-get --reinstall install xulrunner-1.9.1

    to force a re-install of xulrunner.

    I was suspicious that something was wrong with xulrunner when there was no response to "xulrunner" as a command.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •