Results 1 to 9 of 9

Thread: Disable the 'Pointer can be controlled using the keypad' function

  1. #1
    Join Date
    Dec 2007
    Beans
    504

    [Solved] Disable the 'Pointer can be controlled using the keypad' function

    Can anyone tell me how to permanently disable the 'Pointer can be controlled using the keypad' accessibility function?

    There was a post about it on launchpad, that I used before and since updating to 9.10 I can't find it.

    It may be a Gnome bug, and its getting very irritating - maybe 10 - 12 times a day.......

    Any useful help is appreciated - esp if you can name it so I can uninstall it
    Last edited by stoneage; January 4th, 2010 at 07:29 PM.

  2. #2
    Join Date
    Jun 2009
    Location
    0000:0400
    Beans
    Hidden!

    Re: Disable the 'Pointer can be controlled using the keypad' function

    It may help your search to know that this isn't a Gnome feature -- its builtin functionality from The X server.

  3. #3
    Join Date
    Feb 2009
    Beans
    54
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Disable the 'Pointer can be controlled using the keypad' function

    Alt+Shift+Num Lock

    I had this issue and I wanted to look up a solution for you. Really is annoying when you want to use the Numpad but can't.

    Edit: Also System > Assistive Technologies > Keyboard Preferences > Mouse Keys will solve the problem.
    Last edited by Kraust; January 3rd, 2010 at 11:00 PM.
    AMD Duron 700 || 448 MB SDRAM || EVGA GeForce 7300 GT
    20 GB Hard Drive || Windows XP / Ubuntu 10.04 DualBoot. || 500GB WD Elements External
    Proudly Ubuntu since 8.10. Long live 10 year old computers.

  4. #4
    Join Date
    Dec 2007
    Beans
    504

    Re: Disable the 'Pointer can be controlled using the keypad' function

    @falconindy, thanks, that narrows it down a bit, though it also means curing might not be easy. Do you happen to know how to disable it?

    @Kraust, I know, but that only toggles it on and off, it doesn't prevent it re-enabling itself. There is a bug present somewhere and I just want to kill the whole damn feature. I'm completely fed up with it turning itself on.

  5. #5
    Join Date
    Jun 2009
    Location
    0000:0400
    Beans
    Hidden!

    Re: Disable the 'Pointer can be controlled using the keypad' function

    Quote Originally Posted by stoneage View Post
    @falconindy, thanks, that narrows it down a bit, though it also means curing might not be easy. Do you happen to know how to disable it?
    Sadly, I do not. You might try binding something else to it via compiz or xmodmap.

  6. #6
    Join Date
    Dec 2007
    Beans
    504

    Re: Disable the 'Pointer can be controlled using the keypad' function

    Hello again, I found it.....

    For anyone else it is here:-

    Ondřej Buriánek wrote on 2009-11-21: #52 Hello fellow earthlings daily beaten by this bug.
    I used this workaround to permanently disable mousekeys shortcut shift+num-lock, alt+shift+num-lock etc...
    gksudo gedit /usr/share/X11/xkb/compat/complete
    -or-
    sudo nano /usr/share/X11/xkb/compat/complete
    and comment out lines for mousekeys and accesx(full) (for full keyboard accessibility purge)
    resulting file /usr/share/X11/xkb/compat/complete:
    // $XKeyboardConfig$
    // $Xorg: complete,v 1.3 2000/08/17 19:54:34 cpqbld Exp $
    default xkb_compatibility "complete" {
    include "basic"
    augment "iso9995"
    //augment "mousekeys"
    //augment "accessx(full)"
    augment "misc"
    augment "xfree86"
    augment "level5"
    };
    Wish you a lot happy days without moving mouse by keypad
    Greets Ondrej
    https://bugs.launchpad.net/xorg-server/+bug/192508

  7. #7
    Join Date
    Aug 2006
    Beans
    92
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Disable the 'Pointer can be controlled using the keypad' function

    Quote Originally Posted by stoneage View Post
    Hello again, I found it.....

    For anyone else it is here:-
    THANK YOU!!!!!! My God this has bugged me for years. I just finally got fed up & started to google around for it. I really appreciate people, like yourself, coming back to leave an answer for others who come across similar problems.

  8. #8
    Join Date
    Mar 2009
    Beans
    2

    Re: Disable the 'Pointer can be controlled using the keypad' function

    Thank you very much. I had the same problem on Arch Linux, that one fixed it!

  9. #9
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: [Solved] Disable the 'Pointer can be controlled using the keypad' function

    There is another, simple way that has been around for a while. It is in 12.04 and I am sure that it is in 11.10.

    System Settings>Univeral Access> Pointing and Clicking tab. There we can turn off Control the Pointer Using the Keypad.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •