Results 1 to 6 of 6

Thread: Eclipse not working properly in Karmic

  1. #1
    Join Date
    Sep 2008
    Beans
    26
    Distro
    Ubuntu

    Eclipse not working properly in Karmic

    I'm having a very strange issue with Eclipse IDE.

    I had Ubuntu 9.04 then I upgraded to 9.10. Then I wrecked the system and I had to reinstall it without formatting the disk. Since then it seems like the buttons are not working in modal windows in Eclipse.

    For example, if I try to change the build path for a project all I can do is to open the properties window for that project. When I select a jar file and push the Edit button to change it nothing happens.

    I tried with both Eclipse IDE for Java EE Developers and Eclipse IDE for Java Developers but the result was exactly the same. I did not have this problem when I was using 9.04 or after the upgrade to 9.10. It seems like it has something to do with the last installation.

    Any ideas what might be the problem?

    Thanks!

  2. #2
    Join Date
    Oct 2005
    Location
    De Kwakel - Holland
    Beans
    3,657

    Re: Eclipse not working properly in Karmic

    Did you get Eclipse from the repositories?
    If so.. that never worked for me, better get it from the Eclipse site.

    Not sure if this is related..
    I had this issue with Eclipse the mouse wouldn't work when pushing a button but using the keyboard it worked fine.
    So, <tab> to the button and <enter> to push.

  3. #3
    Join Date
    Dec 2005
    Beans
    37

    Re: Eclipse not working properly in Karmic

    Add "export GDK_NATIVE_WINDOWS=true" before starting eclipse.
    This problem will be fixed in Eclispe 3.6 normally.

  4. #4
    Join Date
    Sep 2008
    Beans
    26
    Distro
    Ubuntu

    Re: Eclipse not working properly in Karmic

    Quote Originally Posted by yanns View Post
    Add "export GDK_NATIVE_WINDOWS=true" before starting eclipse.

    That solved the problem. Thank you!

  5. #5
    Join Date
    Nov 2009
    Beans
    3

    Re: Eclipse not working properly in Karmic

    it's solved my problem also

  6. #6
    Join Date
    Nov 2009
    Beans
    3

    Re: Eclipse not working properly in Karmic

    edit eclipse.ini with export GDK_NATIVE_WINDOWS=true

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •