Results 1 to 7 of 7

Thread: resolution problem after upgraded to Karmic 9.10

  1. #1
    Join Date
    Oct 2009
    Beans
    11

    resolution problem after upgraded to Karmic 9.10

    I recently upgraded to 9.10 and found my laptop can only display 800*600 while previously on Juanty, it could show 1024*768. The video chip is Intel i830(82830) on Sony PCG-R505GL. I'm suspecting it's a bug with the latest intel driver(xserver-xorg-video-intel 2.9.0), but not sure. Anything that can walkaround this?
    I've tried dkpg-reconfigure -phigh xserver-xorg and it doesn't work(it doesn't even generate a new xorg.conf;

    I've also manually edited xorg.conf with following entries, but it doesn't work either

    Section "Device"
    #Identifier "Intel Corporation 82830 CGC [Chipset Graphics Controller]"
    Identifier "Intel 82830"
    Driver "intel"
    #Option "MigrationHeuristic" "greedy"
    #Option "AccelMethod" "UXA"
    #Option "AccelMethod" "EXA"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    HorizSync 30-70
    VertRefresh 30-100
    EndSection

    Section "Monitor"
    Identifier "LVDS1"
    HorizSync 30-70
    VertRefresh 30-100
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Intel 82830"
    Subsection "Display"
    Depth 24
    Modes "1024x768"
    EndSubsection
    EndSection

    Section "Screen"
    Identifier "LVDS1 screen"
    Monitor "LVDS1"
    Device "Intel 82830"
    Subsection "Display"
    Depth 16
    Modes "1024x768"
    EndSubsection
    EndSection

  2. #2
    Join Date
    Oct 2009
    Beans
    11

    Re: resolution problem after upgraded to Karmic 9.10

    After searing/testing for the past two days, I still can not fix this, I'll try the following two options
    1. downgrade intel driver
    2. disable i915.lmodeset =0 to see if this will help...

  3. #3
    Join Date
    Oct 2009
    Beans
    11

    Re: resolution problem after upgraded to Karmic 9.10

    I've fixed this by adding the following in /boot/grub/menu.lst
    i915.modeset=0

    This is to disable Kernel probing, which is default enabled since Kernel 2.6.30-10.12, see below the link:
    https://wiki.ubuntu.com/X/KernelModeSetting




  4. #4
    Join Date
    Jun 2005
    Location
    Australia
    Beans
    1,837

    Re: resolution problem after upgraded to Karmic 9.10

    Interesting news.

  5. #5
    Join Date
    Apr 2008
    Beans
    11
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: resolution problem after upgraded to Karmic 9.10

    Why do I not have any menu.lst? Everything has changed in this release. Grub is now a series of .mod files and I found the info from the old menu.lst in a file called grub.cfg but at the top it says DO NOT EDIT THIS FILE.

    Just like a supermarket! As I learn where things are they change it all around. So how am I going to get more than 800x600 on this pc?

    So far this release doesn't seem to work on any old PCs. I usually advocate Ubuntu for running on older hardware. For a long term support release, this is not as "just worky" as it should be.

    Where should I put i915.modeset=0 ?

  6. #6
    Join Date
    Feb 2009
    Location
    Asheville, NC
    Beans
    70
    Distro
    Ubuntu

    Question Re: resolution problem after upgraded to Karmic 9.10

    +1 at stonedancer

    "[SOLVED]"?
    How is this a solved thread? We do not have a menu.lst file under Karmic.
    My 2 cents.

    Same problem here, working with Xorg.conf under Karmic and getting no results. No monitor detection / high resolution options after upgrade to 9.10.
    e.m.fields
    Asheville, nc

  7. #7
    Join Date
    May 2009
    Beans
    20
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: resolution problem after upgraded to Karmic 9.10

    I seem to be having a similar problem. By the way, I beg forgiveness if my post does not add new information, I find my user level lower than that of those who posted before.

    - My computer starts "by default" on 800x600 resolution.

    - If I go to system->preferences->display

    the following message appears:

    " It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphics driver vendor's tool instead?"

    This makes me think that there is some kind of problem with my graphic board's (NVIDIA G-force gtx 285) driver.

    - I accept and then I can change the resolution, there is even an option to

    "save to x-configuration file"

    It does not work due to some permission problem (I don't know how to execute this as superuser).

    - I can however, reproduce what this option is supposed to do as it basically edits the

    /etc/X11/xorg.conf

    file. I edited it manually (there is a show preview option in the nvidia x server settings applications that shows how the file should look like) and... it didn't work... next time I started the computer the display was 800x600 again.

    Any help?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •