Problem started after upgrade from 9.04 to 9.10.

On 9.04, I started x11vnc by executing it from /etc/gdm/Init/Default. The command I use is below (personal info replaced with '~':

/usr/bin/x11vnc -o /var/log/x11vnc -noxdamage -verbose -auth /var/lib/gdm/:1.Xauth -rfbauth /etc/.vncpasswd -rfbport 5900 -shared -forever -bg -scale 3/4 -users ~~~~~ -solid \#003399 -afteraccept "gconftool-2 --type bool --set /desktop/gnome/background/draw_background false" -gone "gconftool-2 --type bool --set /desktop/gnome/background/draw_background true"

This worked fine, and allowed me to see the GDM login screen from a VNC session on bootup. I later set GDM to auto-login.

After upgrading to 9.10, x11vnc is not executed, despite that line being in /etc/gdm/Init/Default. The -o option indicates the file to log to, and that file is not changed upon restart of gdm. Placing that line in /etc/gdm/PreSession/Default causes x11vnc to run without error, when autologin is enabled, but I would like x11vnc to be available with the login screen.

Any ideas why gdm is ignoring /etc/gdm/Init/Default now?