I copied my system disk to a new drive to put with a new motherboard to make the whole system silent. The motherboard is an Intel D945GSEJT mini-ITX, which uses the Atom 270 CPU.

The on-board NIC is not visible to my system.

I am running 8.04 (I think, could be 9.04, but I think it's the last LTS distribution) as a server. The kernel package is 2.6.24-24-generic. I've got the minimum installation plus a few packages to provide network services to a small network (DNS, routing, firewall, etc).

The very first thing I did was find the new HW address:
/var/log/messages.0:Oct  8 17:00:48 portroyal kernel: [   26.032494] eth0: RealTek RTL8139 at 0xb800, 00:e0:18:0a:5f:b6, IRQ 5
... and update /etc/udev/rules.d/70-persistent-net.rules:
# This file was automatically generated by the /lib/udev/write_net_rules
# program run by the persistent-net-generator.rules rules file.
# You can modify it, as long as you keep each rule on a single line.

# PCI device (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:e0:18:0a:5f:b6", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x1814:0x0301 (rt61pci)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:14:a5:9f:b7:21", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

# PCI device 0x168c:0x0013 (ath_pci)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:13:46:9a:28:5c", ATTR{type}=="1", KERNEL=="ath*", NAME="ath0"
After a reboot, the NIC still wasn't there. More importantly, it doesn't show up in dmesg or in /var/log/messages anymore either (note the above snippet is from messages.0, I realized it disappeared at some point but I don't know when).

I've tried manually loading the r8169 driver by adding it to /etc/modules. I've also tried removing all other hardware, which in this case consists of only a wireless card. The on-board NIC is never discovered by the kernel.

Please tell me what to try here so I can get my server back online