Hello

*i posted this on the blenderartist forum but it was not replied too, i think its something to do with my computer and not the game*

I have just downloaded Yo Frankie but it does not work. I am on Ubuntu (yes linux) 8.10 so i ran the yofrankie-linux-i386 file. The start animation and the menu works, controls works too but when i press play it crashes and closes. In the terminal it looks like this:
Quote:
joshua@joshua-laptop:~$ '/home/joshua/blender_game_engine/yofrankie-linux-i386' argv[0] = '/home/joshua/blender_game_engine/yofrankie-linux-i386'
Detected GL_ARB_texture_env_combine
Detected GL_ARB_texture_cube_map
Detected GL_ARB_multitexture
Detected GL_ARB_shader_objects
Detected GL_ARB_vertex_shader
Detected GL_ARB_fragment_shader
Detected GL_ARB_vertex_program
Detected GL_ARB_depth_texture
Detected GL_EXT_separate_specular_color
read library: lib //../chars/butterfly.blend
Warning, sensor "menu_delay" has lost a link to a controller (link 2 of 3) from object "menu_logic"
possible causes are partially appended objects or an error reading the file,logic may be incorrect
Warning, sensor "menu_delay" could not find its controller (link 3 of 3) from object "menu_logic"
there has been an error converting the blender controller for the game engine,logic may be incorrect
Warning, sensor "sensor2" has lost a link to a controller (link 1 of 1) from object "butterfly_logic"
possible causes are partially appended objects or an error reading the file,logic may be incorrect
read library: lib //../props/pickups.blend
read library: lib //../chars/butterfly.blend
read library: lib //../props/plants.blend
read library: lib //../props/flowers.blend
read library: lib //../props/trees.blend
read library: lib //../chars/frankie.blend
read library: lib //../props/fences.blend
read library: lib //../props/platforms.blend
read library: lib //../props/rocks.blend
read library: lib //../hud/hud.blend
read library: lib //../effects/fx_blast.blend
read library: lib //frankie_actions.blend
read library: lib //momo_actions.blend
yofrankie-linux-i386: shader/slang/slang_codegen.c:2442: _slang_gen_var_decl: Assertion `!is_sampler_type(&var->type)' failed.
Aborted
joshua@joshua-laptop:~$
It also crashes in blender. Does anyone know how to fix this error? Thanks in advance.

-joshua