Results 1 to 10 of 699

Thread: HOWTO: Lexmark Printers

Threaded View

  1. #10
    Join Date
    Apr 2008

    Re: HOWTO: Lexmark Printers

    I have a Dell 924 printer which might work with Lexmark drivers. I followed the startpost procedure and some procedures from other posts. I'm at this point that I'm able to create a new printer and select the pps driver(s). Everything looks OK but no printing at all. Can someone please check below if something went wrong in the process?

    -Is it OK that I don't get output when I do this? This should be important for printer backend to find libraries:

    $ sudo ldconfig

    -Then I tried this:
    $ /etc/rc2.d/S19cupsys restart
    bash: /etc/rc2.d/S19cupsys: No such file or directory

    -When I browse to the specific dir, I see this:

    /etc/rc2.d$ dir
    README S30gdm S89atd
    S01policykit S50avahi-daemon S89cron
    S10acpid S50cups S90binfmt-support
    S10apmd S50NetworkManager S98usplash
    S10sysklogd S50pulseaudio S99acpi-support
    S11klogd S50rsync S99laptop-mode
    S12dbus S50saned S99ondemand
    S20apport S50system-tools-backends S99rc.local
    S20dkms_autoinstaller S99rmnologin
    S20hotkey-setup S70dns-clean S99stop-readahead
    S24hal S70pppd-dns
    S25bluetooth S89anacron

    -No S19cupsys there, so I tried this:
    /etc/rc2.d$ S50cups restart
    bash: S50cups: command not found

    -Then tried if backend works, but NO output again:
    /usr/lib/cups/backend$ dir
    beh dnssd hp http lpd scsi smb socket z35
    bluetooth hal hpfax ipp parallel serial snmp usb z600
    es@es:/usr/lib/cups/backend$ ./z35
    es@es:/usr/lib/cups/backend$ ./z600

    UPDATE: did more research but still doesn't work

    -In synaptic I installed al 'cupsys' items

    -Some suggestions from other threads I used:
    sudo mkdir /etc/cups/interfaces/
    sudo gedit /etc/cups/cupsd.config
    file is empty but added:
    #AuthType Basic
    #AuthClass System

    -Added cupsys to the shadow group:
    sudo vi /etc/group (added cupsys manually at the end of the shadow line)

    -Restart of cupsys doesn't work, but this does:
    sudo /etc/init.d/cups stop
    sudo /etc/init.d/cups start

    -I tried this to deactivate the AppArmor protection of CUPS temporarily:
    sudo aa-complain cupsd

    -Wich version of cupsys is installed:
    dpkg -l cupsys | cat
    | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Naam Versie Omschrijving
    ii cupsys 1.3.9-17ubuntu3 Common UNIX Printing System (transitional package)

    -I worked with CUP via GUI at http://localhost:631
    I can add/manage printers and assign drivers. When I check System->Administration->Printing it shows a printer (with a green V or with a red hearth) but when I try to print it says that the printer is offline.

    -I added a printer manually:
    Via System->Administration->Printing and everything looks OK, it even says that the printer is online/connected. But nothing happens
    Last edited by winterg; May 9th, 2009 at 09:32 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts