Results 1 to 7 of 7

Thread: Printer installed but not according to HP-Toolbox

Threaded View

  1. #1
    Join Date
    Feb 2008

    Exclamation [SOLVED]Printer installed but not according to HP-Toolbox

    Hi all.

    Bit of a nightmare really. I built a computer for my mother-in-law after christmas and was running sweet. She took it home and still running sweet but the HP CP1215 laserjet colour printer has for some reason started to malfunction. Why not just go over and fix it up? My mother-in-law lives about 750kms away!

    So, we've been trying to fix it online and over the phone. She has been doing great. We've managed to uninstall and reinstall HPLip, run hp-setup and eventually installed the printer. According to hp-setup, it's good to go; correct device and bus # and fine.

    Open System->HP-Toolbox and the printer shows up in the left column, but in the right pane is the message:

    ERROR: No device found or unsupported device.

    Try and print: nothing. In other words, we have hit a bit of a brick wall. Setup says the printer is installed, Toolbox says it is and isn't. No printing. Tried deleting the printer and in Toolbox going 'Device->Setup New Device' but that takes up back to the HP-Setup window (on her machine - oddly it takes me to a GUI Wizard on mine) and sets it up again to the same result and error message. Wondered if this was a permission problem but when you type:

    sudo hp-toolbox

    ... in a terminal, same result. Doesn't matter if you launch as root or normal user.

    Anyways, we are desperate for any help with this as this printer has been offline for 3 months and my M-I-L needs to use it pretty urgently by now and as you can imagine, is sick of trying to fix it. Good on her for the patience and persistence. She decided to try Linux after years of MS and loves it ... apart from this little hiccough! She has even been digging around in the console (with my instruction)!

    Tnx in advance ...

    Just to add to the confusion, this site says to use foo2jz:

    But this site from HP seems to give definite proof that it works with HPLip, and that is how I had it working when it left here:
    Last edited by Bucky Ball; July 25th, 2009 at 05:49 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts