Results 1 to 10 of 1334

Thread: HOWTO: Jaunty Intel Graphics Performance Guide

Threaded View

  1. #11
    Join Date
    Jun 2008
    Beans
    49

    Re: HOWTO: Jaunty Intel Graphics Performance Guide

    Quote Originally Posted by psyke83 View Post
    Well, if you're using the 2.6.30-rc2 kernel, you'll notice that the write-combining range is active when you first boot your computer (without any need for the script). When you restart X, however, the write-combining range disappears - in this case, you should use the script.

    Therefore, use the script only if you have restarted X.
    This does seem to reflect what I'm experiencing except the MTRR fix doesn't really seem to change anything for me; I need to reboot to get that extra MTRR line back. Note that having or not these values seem to change the status of my problems (which perhaps are slightly different?)

    Running an Inspiron 700m so I have an 855GME and have applied your guide and upgraded to the latest kernel/driver/etc. I do see the performance increase in ppracer. [Note I had not tried just turning on UXA under the default setup, but that is 2d and doesn't related to 3d]

    My issue seems to be related to closing a graphics app. If I close ppracer (3d) it hangs. If I close world of goo (2d I think?) it hangs. If I play a flash video and close that tab it hangs. Note first I thought it was X hanging in the case of the games, but if I launch the game from a terminal, then I can kill/close the terminal to close the app (note I can't terminate the app directly)

    Video does seem to play slowly in Totem... but fine in VLC and Flash (although Flash seems to intermitedly stick and needs a boot, by moving the slider on the movie timeline, to unstick it).

    Anyway... at least for the hanging games, at least I have a way to play them without having to reboot and more importantly a way to reproduce this problem without needing to reboot as I look for a solution.

    If you have any suggestions for running a debugger to identify what is actually getting stuck (driver/x/whatever) I'll see what I can do

    [OK I've had a couple hangs launching ppracer... weird how it worked well for a while and now just doesn't with no change that I know if]
    Last edited by Craig73; April 28th, 2009 at 09:17 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •