Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Upgrade to 9.04 killed remote desktop viewing

  1. #1
    Join Date
    Jan 2006
    Location
    MA
    Beans
    97
    Distro
    Xubuntu

    Upgrade to 9.04 killed remote desktop viewing

    Upgraded from 8.10 to 9.04. I had remote desktop turned on, and used VNC to access (through SSH when not at home, otherwise just vnc directly).

    Now anytime I connect, I get a view of my desktop, but the image never refreshes (I have a clock widget that normally ticks away seconds...it's accurate when I initiate the vnc session, but never increments afterwards). The mouse cursor appears to move, but any action I take (e.g. click to open a terminal) does nothing. UNLESS I close vnc, and reopen...then I see terminal has opened, but typing does not refresh the screen.

    So everything appears to be working through VNC, it's just that my screen is not getting refreshed.

    VERY frustrating, as now I cannot use my Ubuntu box remotely (which is what I do most times)...

    Any known issues/fixes? Couldn't find anything in this forum...

  2. #2
    Join Date
    Jun 2007
    Beans
    3

    Re: Upgrade to 9.04 killed remote desktop viewing

    I have exactly the same problem. I upgraded to 9.04 and
    now vnc from a remote client connects to my 9.04 machine OK,
    but shows a static screen. However, keyboard input
    and mouse input from the remote client actually DOES
    control the 9.04 machine - I can see that when I walk over to
    the 9.04 machine and watch its local display. I just don't see
    the desktop refresh on the remote client - not even when I
    manually ask for a refresh.
    This problem happens with 2 different vnc remote clients, both of
    which work properly when connected to a ubuntu 8.10 machine.

    TJ O'Donnell

  3. #3
    Join Date
    Oct 2007
    Beans
    15

    Re: Upgrade to 9.04 killed remote desktop viewing

    I too have the same issues, on both ubuntu and kubuntu 9.04 after the upgrade.

    Go into Preferences, Remote Desktop; make the required changes, add a password, click Close.

    Go back to other machine, attempt to vnc in, can access, cannot control. First time I received an authorization notice about multiple users controlling the desktop on the ubuntu machine, set that to always remember the authorization. Now, it still doesn't work, and if I reboot, the applet doesn't remember the information I put in previously.

  4. #4
    Join Date
    Apr 2009
    Beans
    2

    Re: Upgrade to 9.04 killed remote desktop viewing

    I too am in the same boat! I just upgraded my server to 9.04 today and my remote desktop is doing exactly like you guys have said. My Windows machine isn't refreshing the screen showing what is going on on my Ubuntu machine, however the mouse movement is the only thing that is refreshing.

    Help quick on this cause I need VNC access to my server asap!

  5. #5
    Join Date
    Feb 2007
    Location
    Spain
    Beans
    79
    Distro
    Kubuntu 8.04 Hardy Heron

    Re: Upgrade to 9.04 killed remote desktop viewing

    Disabling compiz worked for me in the Appearance preferences.
    https://bugs.launchpad.net/ubuntu/+s...no/+bug/353126

  6. #6
    Join Date
    Apr 2009
    Beans
    2

    Re: Upgrade to 9.04 killed remote desktop viewing

    Thanks... I disabled all visual effects and as soon as I did it cleared things right up. My video card is an ATI btw so it appears that this is a known issue with both nvidia and ATI chipsets.

  7. #7
    Join Date
    Jan 2006
    Location
    MA
    Beans
    97
    Distro
    Xubuntu

    Re: Upgrade to 9.04 killed remote desktop viewing

    Not much of a fix...I really like my compiz effects! Saw the bug listed in that link. Let's hope it's fixed soon!!!
    Last edited by Metallinut; April 28th, 2009 at 11:09 PM.

  8. #8
    Join Date
    Jun 2007
    Beans
    3

    Re: Upgrade to 9.04 killed remote desktop viewing

    I am able to get remote desktop access when I switch off
    compiz under Preferences/Appearance. Thanks for the tip.
    Sure would be nice if the Remote Desktop setup would
    have some way to automate that.

  9. #9
    Join Date
    Apr 2009
    Location
    Southfield, MI
    Beans
    75
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Upgrade to 9.04 killed remote desktop viewing

    I had this issue also, disabling compiz allowed me to control remote Jaunty machine. I can do without it for now, it's a dedicated HTPC with full install of Jaunty.
    Sys1: Biostar TA790GX w/ AMD 790GX, ATi 3300, AMD Athlon 64 X2 5000+, G.Skill 4096 DDR 1066 RAM.
    http://valid.canardpc.com/cache/banner/775784.png

  10. #10
    Join Date
    May 2009
    Location
    nancy, France
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Upgrade to 9.04 killed remote desktop viewing

    thanks for this workaround, works great.

    i should have checked this first, somehow i knew this had something to do with compiz

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •