Don't know if its just something I did wrong, but with:

options snd-hda-intel model=acer-aspire

Headphone mute didn't work, but I have it working after replacing that line with:

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto