Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Bluetooth mouse and keyboard won't stay connected.

  1. #1
    Join Date
    Apr 2007
    Beans
    19

    Bluetooth mouse and keyboard won't stay connected.

    I just did a fresh install of 8.1, and I can't get my bluetooth mouse and keyboard all fixed. Everytime I let them idle for more than ~5 minutes, I have to reconnect with with sudo hidd--search. I've looked around for a way to solve it, but no luck.

    Here is what my /etc/default/bluetooth looks like:

    # Defaults for bluez

    # start bluetooth on boot?
    # compatibility note: If this variable is not found bluetooth will
    # start
    BLUETOOTH_ENABLED=1

    # This setting will switch HID devices (e.g mouse/keyboad) to HCI mode, that is
    # you will have bluetooth functionality from your dongle instead of only HID.
    # Note that not every bluetooth dongle is capable of switching back to HID
    # mode, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355497
    HID2HCI_ENABLED=1
    HID2HCI_UNDO=1
    HIDD_ENABLED=1
    HIDD_OPTIONS="-i --connect 00:12:5A:10:7A:7E --connect 00:12:5A:10:1E:7F --server"

  2. #2
    Join Date
    Apr 2007
    Location
    Brussels
    Beans
    105
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Bluetooth mouse and keyboard won't stay connected.

    The quick and dirty approach I would take is to put something in the crontab that executes the reconnect command every 2 minutes. Instructions on how to do that are here:
    http://neeocis.wordpress.com/2008/07...-five-minutes/

    Maybe you have something disrupting the communications between the devices, do the same issues occur in other operating systems, if there are any (like Windows?)

    Hope that helped

    Leon
    Microsoft gives you BSOD.
    Apple gives you style.
    Linux gives you power.

  3. #3
    Join Date
    Apr 2007
    Beans
    19

    Re: Bluetooth mouse and keyboard won't stay connected.

    It's not an issue on windows XP, I don't think anything is disrupting the signal, it's more like the devices go into sleep after idling for a few minutes, and when I use them, they don't auto re-connect.
    Also, I tried using contrab, but it didn't work
    Last edited by Raziekiel; December 24th, 2008 at 05:51 AM.

  4. #4
    Join Date
    Apr 2007
    Beans
    19

    Re: Bluetooth mouse and keyboard won't stay connected.

    /bump
    Any ideas???

  5. #5
    Join Date
    Sep 2007
    Location
    Texas
    Beans
    74
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Bluetooth mouse and keyboard won't stay connected.

    You can try this page and see if there is anything additional on it you haven't tried yet.

    https://help.ubuntu.com/community/BluetoothSetup

    Update #2:
    I decided to break back out my bluetooth stuff and give it a go once again. Gave up on it a while back because I was switching alot between Windows and Linux at the time and couldn't get the bluetooth to transfer, but anyways, here is my /etc/default/bluetooth.

    # Defaults for bluez

    # Defaults for bluez

    # start bluetooth on boot?
    # compatibility note: If this variable is not found bluetooth will
    # start
    BLUETOOTH_ENABLED=1

    # This setting will switch HID devices (e.g mouse/keyboad) to HCI mode, that is
    # you will have bluetooth functionality from your dongle instead of only HID.
    # Note that not every bluetooth dongle is capable of switching back to HID
    # mode, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355497
    HID2HCI_ENABLED=1
    HID2HCI_UNDO=1
    HIDD_ENABLED=1
    HIDD_OPTIONS="--connect 00:07:61:4E:43:C2 --connect 00:07:61:4E:31:9F --server"
    I got both my mouse and keyboard hooked up now and both come to life when I get to the login screen after a fresh boot up or restart. I am also using Ubuntu 8.10.
    Last edited by Law506; December 26th, 2008 at 08:35 PM. Reason: Hooked up both bluetooth devices.

  6. #6
    Join Date
    Feb 2008
    Location
    At a desk.
    Beans
    192

    Re: Bluetooth mouse and keyboard won't stay connected.

    Next time your Bluetooth mouse/keyboard falls asleep, open a terminal and type in the following command (yes, I know this necessitates getting another keyboard!! )

    Code:
    $ sudo hciconfig hci0 pscan
    Wait a few seconds and start wiggling your mouse to see if it comes back to life. If it does, great - your Bluetooth adapter was not actively scanning for devices to reconnect.

    Rebooting will lose this change, so until a permanent bugfix is made, just stick the command into your /etc/rc.local file before the "exit 0" line so it gets executed on every startup.

    NOTE ABOUT THIS WORKAROUND: Depending on your Bluetooth devices, Ubuntu may still not connect to them if they already had a "connected" status, eg: when you reboot. The simplest way to get them to reconnect is to switch them off and on again and Ubuntu will then pick them up a few seconds later. You can power cycle right away rather than wait for Ubuntu to completely restart and they should be usable again even from the login screen.
    Racecar is just Racecar spelt backwards...

  7. #7
    Join Date
    Apr 2007
    Beans
    19

    Re: Bluetooth mouse and keyboard won't stay connected.

    Alright, here is my current /etc/default/bluetooth

    # Defaults for bluez

    # start bluetooth on boot?
    # compatibility note: If this variable is not found bluetooth will
    # start
    BLUETOOTH_ENABLED=1

    # This setting will switch HID devices (e.g mouse/keyboad) to HCI mode, that is
    # you will have bluetooth functionality from your dongle instead of only HID.
    # Note that not every bluetooth dongle is capable of switching back to HID
    # mode, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355497
    HID2HCI_ENABLED=1
    HID2HCI_UNDO=1
    HIDD_ENABLED=1
    HIDD_OPTIONS="--connect 00:12:5A:10:7A:7E --connect 00:12:5A:10:1E:7F --server"

    I tried the pscan command as well, but it didn't pick up my mouse or keyboard.

    I'm running 64bit if that matters. Any other ideas?

    *UPDATE*
    I was looking around for other ideas and came across the /etc/bluetooth/input.conf file and found
    Code:
    # Configuration file for the input service
    
    # This section contains options which are not specific to any
    # particular interface
    [General]
    
    # Set idle timeout (in minutes) before the connection will
    # be disconnect (defaults to 0 for no timeout)
    #IdleTimeout=30
    I changed IdleTimeout to 0 so it won't time out anymore (hopefully).

    // Changing the IdleTimeout didn't seem to matter...
    Last edited by Raziekiel; December 29th, 2008 at 09:33 PM.

  8. #8
    Join Date
    Feb 2008
    Location
    At a desk.
    Beans
    192

    Re: Bluetooth mouse and keyboard won't stay connected.

    I'm running 64-bit as well - no dramas. My /etc/default/bluetooth is far simpler than yours:

    Code:
    # start bluetooth on boot?
    # compatibility note: If this variable is not found bluetooth will
    # start
    BLUETOOTH_ENABLED=1
    
    # This setting will switch HID devices (e.g mouse/keyboad) to HCI mode, that is
    # you will have bluetooth functionality from your dongle instead of only HID.
    # Note that not every bluetooth dongle is capable of switching back to HID
    # mode, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355497
    HID2HCI_ENABLED=1
    HID2HCI_UNDO=1
    The reason I don't have the HIDD_ENABLED and HIDD_OPTIONS lines is that I do not have the bluez-compat package installed that contains the hidd command, because it is not supposed to be part of Intrepid anymore.

    Can I suggest as an experiment that you boot up on a LiveCD (or a VM) so that you have a fresh, default environment to work with, pair your mouse and keyboard as normal and then issue the sudo hciconfig hci0 pscan command and see how you go? I've now setup four machines with Intrepid and Bluetooth mice (cabled keyboards, though) and they are currently working perfectly with this workaround.

    Also, the disconnection timeout is generally a function of the hardware, not software. The keyboard and mouse disconnect themselves to conserve battery when idle.
    Racecar is just Racecar spelt backwards...

  9. #9
    Join Date
    Dec 2007
    Location
    portland oregon
    Beans
    20
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Bluetooth mouse and keyboard won't stay connected.

    using a microsoft bluetooth mouse 5000 on a lenovo s10

    under 8.10 I connected once but never again. pscan didn't seem
    to make a difference.

    under 9.04 which has later bluez-gnome, pscan method makes no difference. the applet shows a connect button, but no function for
    the mouse after using. removing the mouse device and reconnecting using the '+' button adds the mouse to the device list but does not show mouse function. the mouse flashes intermittant led signals like it is still trying to sync.

    there is a bug open on this:
    https://bugs.launchpad.net/ubuntu/+s...me/+bug/285007

  10. #10
    Join Date
    Feb 2008
    Location
    At a desk.
    Beans
    192

    Re: Bluetooth mouse and keyboard won't stay connected.

    Quote Originally Posted by newore View Post
    using a microsoft bluetooth mouse 5000 on a lenovo s10

    under 8.10 I connected once but never again. pscan didn't seem
    to make a difference.
    Works perfectly for me under 8.10. Worse-case scenario is when I reboot - I just need to switch the mouse off and then on again and it reconnects a few seconds later without needing to redo the Bluetooth pairing. I've also never had any sleeping issues.

    Can you enter just:
    Code:
    $ sudo hciconfig hci0
    ...and post up the output? It should look similar to this:

    Code:
    hci0:	Type: USB
    	BD Address: 00:BB:CC:00:33:FF ACL MTU: 310:10 SCO MTU: 64:8
    	UP RUNNING PSCAN 
    	RX bytes:766 acl:0 sco:0 events:34 errors:0
    	TX bytes:401 acl:0 sco:0 commands:34 errors:0
    
    $
    If it does not show "UP RUNNING PSCAN", then your Bluetooth adapter is not actively scanning and the mouse will not auto reconnect.
    Racecar is just Racecar spelt backwards...

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •