Results 1 to 10 of 26

Thread: [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

Threaded View

  1. #1
    Join Date
    Dec 2008

    [SOLVED] Huawei e169 USB modem - Virgin Broadband - Australia [solved]

    Been tearing my hair out for two weeks now with this one but I did get it to work.

    I have Ubuntu 8.10, Huawei e169 USB modem and Virgin Broadband. The modem was detected no problems although shows up as an E620, but that doesn't seam to matter, I created the connection in the nm-applet and it looked like it was trying to connect but would immediately disconnect or keep asking for the password which wouldn't work.

    It does seam the new network manager has alot of problems to sort out yet, the particular one causing me grief was that I couldn't change the settings on the PPP tab of the connection editor. I could change the check boxes but the changes are not retained.

    With Virgin,it seams, you must login with PAP authentication, but because I couldn't disable CHAP authentication in the connection editor I was unable to connect successfully

    To fix
    sudo gedit /etc/ppp/options

    find the line that says
    and uncomment it (delete #)
    this (I think) disables CHAP authentication

    I also had to change the APN to VirginBroadband instead of VirginInternet which was the default And now its happy.

    Other settings
    Number *99#
    Uname <your virgin username>
    PW <your virgin password>

    Hope this helps someone else.

    One other warning on this type of connection. Your machine is visible on the net. Make sure you install a firewall (eg firestarter)to protect yourself.
    Last edited by step_god; December 18th, 2008 at 12:55 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts