Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: [SOLVED] Epson V300 flatbed scanner support

  1. #1
    Join Date
    Jun 2008
    Location
    California
    Beans
    2,271
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Epson V300 flatbed scanner

    I wondered if anyone has gotten the Epson V300 flatbed scanner working with Ubuntu 8.04 or 8.10. I checked the Avasys and Sane sites but neither shows the V300 as a supported model. In another thread, Tuxi had no success getting this scanner working.

    BTW, the V300 is the successor to the V200 and is Epson's current budget flatbed scanner.

    AVASYS SITE:
    http://avasys.jp/hp/page000001300/hpg000001243.htm

    THREAD CONTAINING TUXI'S POST
    http://ubuntuforums.org/showthread.p...00#post6257709

    SANE SITE
    http://www.sane-project.org/cgi-bin/...&bus=any&v=&p=
    Last edited by kaibob; April 17th, 2009 at 05:11 AM.

  2. #2
    Join Date
    Jun 2008
    Location
    California
    Beans
    2,271
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Epson V300 flatbed scanner support

    I just checked the Avasys site, and the V300 is now supported. Also, for the first time, Ubuntu is shown as a distribution. Sounds great

  3. #3
    Join Date
    Jan 2007
    Beans
    79

    Re: Epson V300 flatbed scanner support

    I have got the V300 working using the drivers provided on the Avasys site for Ubuntu 8.04.

    You need to make sure that:

    - Sane and Sane-utils are installed prior to installing the Avasys drivers,
    - Both the iscan and esci-interpreter packages from Avasys are installed and,
    - A line with "epkowa" is added to the /etc/sane.d/dll.conf file

    Running "sane-find-scanner" and "scanimage -L" in a terminal window should confirm that your scanner is recognised and then running "iscan" should allow you to scan images.

    I have tested both paper and transparency (film negative) scanning using iscan and they work fine.

    I tried Xsane but found that it would not run previews when scanning film negatives. The error message "Failed to start scanner: invalid argument" would appear when I pressed the Preview button in Xsane.


    Jonam

  4. #4
    Join Date
    Mar 2005
    Location
    Devon, UK
    Beans
    306

    Re: [SOLVED] Epson V300 flatbed scanner support

    I have just tried following your method but there is a dependency problem with iscan on intrepid. It needs libltdl3 which isn't available in the 8.10 repos.

  5. #5
    Join Date
    Mar 2005
    Location
    Devon, UK
    Beans
    306

    Re: [SOLVED] Epson V300 flatbed scanner support

    I installed libltdl3 using the hardy package.

    http://packages.ubuntu.com/hardy/libltdl3

    Then just followed Jonam's instructions (thanks)

    The avasys iscan app works but is very basic. Xsane works as well and gives much more control.

  6. #6
    Join Date
    Jun 2006
    Location
    Katy, TX USA
    Beans
    31
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: [SOLVED] Epson V300 flatbed scanner support

    Quote Originally Posted by bailout View Post
    I installed libltdl3 using the hardy package.

    http://packages.ubuntu.com/hardy/libltdl3

    Then just followed Jonam's instructions (thanks)

    The avasys iscan app works but is very basic. Xsane works as well and gives much more control.
    Thanks to everyone on this thread. I was able to get the 64-bit version to work! (I used the libltdl3 package from Hardy.) Interestingly enough, running iscan from the command line gave me a message that it was unable to communicate with the scanner, but running "Image Scan!" from the graphics menu started the scanner right up

  7. #7
    Join Date
    Nov 2007
    Beans
    254

    Re: [SOLVED] Epson V300 flatbed scanner support

    I need to run iscan with root permissions, can i do something about that? Maybe change the permissions of the mountpoint or something like that?
    they stole our revolution. we stole it back. they hired us to work on it. and now we're occupying the plant. -@mala

  8. #8
    Join Date
    Feb 2009
    Location
    Irvine
    Beans
    28
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: [SOLVED] Epson V300 flatbed scanner support

    to install libltdl3 it asks me to remove the current software manager. Does that mean I need to remove libltdl7? Looks like a big deal. any other way to get V300 to work? [EDIT: Never mind, I might have had Synaptic open which caused a conflict !?]
    Last edited by ogger; February 22nd, 2009 at 07:37 AM.

  9. #9
    Join Date
    Sep 2007
    Location
    Lancashire, UK
    Beans
    41
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: [SOLVED] Epson V300 flatbed scanner support

    Hi,

    Just got one of these scanners and have tried to follow this thread to get it working but when I tried to install the .deb package I got the following errors:

    root@Office-desktop:/home/stuart# dpkg --install iscan_2.19.0-4_i386.deb
    (Reading database ...
    dpkg: serious warning: files list file for package `iscan' missing, assuming package has no files currently installed.
    145760 files and directories currently installed.)
    Preparing to replace iscan 2.19.0-4 (using iscan_2.19.0-4_i386.deb) ...
    /var/lib/dpkg/tmp.ci/preinst: 17: Syntax error: Bad substitution
    dpkg: error processing iscan_2.19.0-4_i386.deb (--install):
    subprocess pre-installation script returned error exit status 2
    /var/lib/dpkg/tmp.ci/postrm: 25: Syntax error: Bad substitution
    dpkg: error while cleaning up:
    subprocess post-removal script returned error exit status 2
    Errors were encountered while processing:
    iscan_2.19.0-4_i386.deb

    I have 7.10 installed at the moment on my 32bit box, I have also tried it on my 64bit box running 8.04.

    Cheers
    Stu
    Thanks,
    Stu

  10. #10
    Join Date
    Nov 2007
    Beans
    254

    Re: [SOLVED] Epson V300 flatbed scanner support

    I think you first have to remove all iscan packages before you install new ones.
    they stole our revolution. we stole it back. they hired us to work on it. and now we're occupying the plant. -@mala

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •