Results 1 to 2 of 2

Thread: [SOLVED] Problem setting up zd1211b WiFi Link USB Adapter for NDS

  1. #1
    Join Date
    Oct 2008
    Ubuntu 12.04 Precise Pangolin

    [SOLVED] Problem setting up zd1211b WiFi Link USB Adapter for NDS

    I've been trying to set my WIFI Link USB Adapter ( in Ubuntu and still didn't manage to. I've found this thread by henrik_daver and it was quite helpful, but still it isn't working, so let me tell you what I've got. First, some outputs

    Bus 005 Device 003: ID 0ace:1215 ZyDAS
    Bus 005 Device 001: ID 0000:0000
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 001: ID 0000:0000
    >usbmodules --device /proc/bus/usb/005/003
    Note: zd1211rw is already on modprobe.d/blacklist

    So, I follow the steps given by henrik, with one slight modification:

    modprobe -r zd1211b
    modprobe -v zd1211b
    modprobe zd1211b
    ip link set dev wlan0 up
    iwconfig wlan0 mode master key off
    iwconfig wlan0 essid "NSD-WFC"
    ifconfig eth0 up
    ifconfig wlan0 up
    brctl addbr br0
    brctl addif br0 eth0
    brctl addif br0 wlan0
    ifconfig br0 up
    dhcpcd br0
    I set the bridge's IP as so I won't lose my internet connection. I figured the IP is meant to share the internet connection, just like I have to set eth0 to for ADSL to work.

    Anyway, the result is that my DS detects the network, it tries to connect(the signal icon turns green), but it fails with a 52101 error or something alike(really, sometimes it's that, sometimes it's 52000... it varies). Also, dhcpcd stops mostly a minute after I start it, I wonder if that's a bad sign as well.

    Truth is, the device is somewhat buggy, for in Windows, if you disconnect and reconnect the USB, the network won't work unless you restart the PC(at least with me, and yes, I have contacted the manufacturer already). It still doesn't make sense, though, and the manufacturer doesn't provide any support for Linux. Actually, they say "it does not work under Linux system", but I guess it's just bulshit, because the install CD provides drivers(buggy code, didn't compile) and guides for installing it on Linux.

    So, that's it all. Any help is appreciated, any further information you need to help me solve this problem, just ask and I'll provide.

    Thanks in advance.
    Last edited by guedesav; November 3rd, 2008 at 02:12 AM. Reason: Shortening topic. Also, bumping!

  2. #2
    Join Date
    Oct 2008
    Ubuntu 12.04 Precise Pangolin

    Talking Re: Problem setting up zd1211b WiFi Link USB Adapter for NDS

    Okay, "thanks a lot" for all your help, I've got some help elsewhere(special thanks for timemage, on the ##linux IRC room), and for all of you who found this topic and is experiencing the same problem, here's what I did...

    After having the driver compiled, zd1211rw o blacklist and et cetera, everything is "almost" done. First, we need to configure dhcp. It has to include a subnet for the wlan0(or whatever interfce the device maps to):

    subnet netmask {
    option routers;
    option subnet-mask;
    option domain-name-servers,;
    option ip-forwarding on;
    range dynamic-bootp;
    default-lease-time 21600;
    max-lease-time 43200;
    DNS values may vary. Now, next thing to do is put the device to actually work! Step by step...

    iwconfig wlan0 mode master
    iwconfig wlan0 essid "NSD-WFC"
    iwconfig wlan0 key:senha
    Here we're configuring the network. It can be done through /etc/network/interfaces, but I still haven't got the time to research more about it. Also, sometimes I feel the signal is horribly down, so I added a "power off" option to turn off power saving. Next!

    ifconfig wlan0
    This will make so that wlan0 is the router to the wireless network. Simple like this.

    /etc/init.d/dhcp restart
    This will enable DHCP in the wireless. If DHCP fails, it might be because another interface(avahi generated, for example) is trying to be DHCP-ed, but it can't. Anyway, there can be several causes, and I can't guess what it'll be. Just wish it works right!

    iptables -t nat -A POSTROUTING -s -j MASQUERADE
    This will allow internet sharing through your wireless interface, so the DS will be able to connect. Now test the connection and have fun!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts