Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: [SOLVED] No letters appear in OpenOffice programs.

  1. #1
    Join Date
    Nov 2008
    Location
    Brazil
    Beans
    309
    Distro
    Ubuntu 9.10 Karmic Koala

    [SOLVED] No letters appear in OpenOffice programs.

    I'm using Ubuntu 8.10 for about a week now and yesterday I opened Writer and saw that no text appeared:









    As you can see it happens with all OO programs. Also I didn't notice before as it was the first time I was gonna use it.I thought it could be because I was using Portuguese as system language so I turned to English and it didn't alter. Since I need these programs I decided to reinstall Ubuntu, now in English. After reinstall it showed the text normally (btw just like with the live-cd). Then I used update-manager and downloaded and installed those circa 72 MB of first-update files, restarted and, when opened OO, there it was the problem again.
    Afterwards I installed java packages to see if it would help (you see I'm really a guesser), but no. Then I update to OO 3.0 (by adding this link deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main to third-party software sources; it updates java and OO perfectly) but the problems, as you see, persists.
    If necessary I can reinstall Ubuntu again to try to catch more exactly when the problem appears (if it appears) but I would rather not do that.
    Maybe some source code fiddling can resolve?
    Well, as a last information, there's a kind of a bug when Ubuntu opens the cd tray at the end of install or live-cd, it opens and closes immediately so once it scratched the cd when I tried to pull it out and since everything else in the os is working perfect I would think this isn't the cause for the problem.
    Obs: actually the text flashes quickly when you point to a button for ex.
    Last edited by ikisham; November 22nd, 2008 at 05:27 PM. Reason: Adding information

  2. #2
    Join Date
    Dec 2007
    Location
    *eating something*
    Beans
    702
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: No letters appear in OpenOffice programs.

    The CD issue was a udev bug that can be solved by doing an upgrade on all your packages. To get your CD back, just wait for the restart and then eject the drive while the bios is doing it's business.

    As for OO.o, wtf? My first guess was some gtk settings with the theme you are using, but if it is only an OO.o issue, then I don't know....

    That CD drive thing annoyed the heck out of me, though.
    |>[HowTo] Bump The BUMP Thread<||>Stats<||>19k<||>23k<||>26k<||>34k<||>37k<||>38k<||>39k<||>40k<|

    Quote Originally Posted by lukjad007
    Backups are usually a good thing unless it's a sewer.

  3. #3
    Join Date
    Nov 2008
    Location
    Brazil
    Beans
    309
    Distro
    Ubuntu 9.10 Karmic Koala

    Solved!

    Found this at the OpenOffice forum:
    http://user.services.openoffice.org/...p?f=16&t=10183
    Thank you anyway. Now I'll only go back to Windows when/if it becomes open source software!=D>
    Details: actually the only box to disable is 'screen font anti-aliasing'. Since if one has the same problem wont see anything that's written, it is the second of the five checked squares in the first column of the tools>options>view box. Actually the letters are now jagged.
    Found the cause: I have a GF4 MX-460-VTP gpu with NVIDIA accelerated graphics driver (version 96), I disable it, restarted and now anti-aliasing is working. Could that be fixed someway?
    Last edited by ikisham; November 22nd, 2008 at 08:40 PM. Reason: Sorry, wrong information! Now correct!

  4. #4
    Join Date
    Nov 2008
    Location
    Brazil
    Beans
    309
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: No letters appear in OpenOffice programs.

    Just one last point. I've opted to keep NVIDIA driver enabled, this makes all OpenOffice.org programs unable to apply anti-aliasing to the fonts so being somewhat with a jagged appearance. I would really want to know if that can be fixed. Maybe some command line settings (for example: where do I find the README for the driver?). The driver I use (version 96) is for kinda old gpus so I don't know if much ppl are interested unless it affects other versions too. Should I post somewhere else in the forum? Is this a problem to be reported as a bug?
    Thanx for your kind help.

  5. #5
    Join Date
    Nov 2008
    Location
    Brazil
    Beans
    309
    Distro
    Ubuntu 9.10 Karmic Koala

    Now completely solved!

    I deactivated nVidia driver and reactivated it some times to make some tests and now OpenOffice 'screen font anti-aliasing' is working perfectly well.
    To put short, the solution could have been: uncheck 'screen font antialiasing' in OO tools>options>view; deactivate nVidia driver: restart; activate nVidia driver; restart; check 'screen font antialiasing' and it's done.

  6. #6
    Join Date
    Nov 2008
    Location
    Brazil
    Beans
    309
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: No letters appear in OpenOffice programs.

    I'm reopening here since I've reinstalled ubuntu 8.10 and can't make 'screen font antialiasing' work in OO with visual effects set to 'normal'.
    I found a solution here:
    https://bugs.launchpad.net/ubuntu/+s...96/+bug/294076
    The last post said this:
    "I have been looking at several forums and doing a lot of Google-ing about this bug these last few days and it seems to me that:

    1. Many people have been affected by this with their legacy cards.
    2. It manifests itself with many different applications..OOv3, Opera, K3b, GoogleEarth....
    3. There are several proposed "fixes" such as anti-aliasing, turn off compositing, the one above from TexasRanger.
    4. Some work for some and not for others.
    5. For me (Geforce4 MX440 card with 96beta driver on Intrepid) I changed my xorg.conf file to

    Option "RenderAccel" "False"
    or
    Option "RenderAccel" "0"

    in the Section "Device"."

    So I came here since I think it's the most adequate forum to ask a simple question: how do I change my xorg.conf file?
    Btw, I'm using Geforce4 MX460-VTP.

  7. #7
    Join Date
    Nov 2008
    Location
    Brazil
    Beans
    309
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: No letters appear in OpenOffice programs.

    I put sudo gedit /etc/X11/xorg.conf and got this:

    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth 24
    Option "AddARGBGLXVisuals" "True"
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    Option "NoLogo" "True"
    EndSection

    So or the command should be other or I don't have this Option "RenderAccel"

    Well I'm trying to google this but if anybody sees it, pls help.

  8. #8
    Join Date
    Nov 2008
    Location
    Brazil
    Beans
    309
    Distro
    Ubuntu 9.10 Karmic Koala

    How to change xorg.conf files

    Well, I have this basic question here. I'm trying to fix the nVidia 96 driver problem with 'screen font anti-aliasing' in OpenOffice.
    The original post is here:
    http://ubuntuforums.org/showthread.p...24#post6230724
    Thank you very much.

  9. #9
    Join Date
    Feb 2007
    Beans
    24,819
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: How to change xorg.conf files

    Quote Originally Posted by ikisham View Post
    Well, I have this basic question here. I'm trying to fix the nVidia 96 driver problem with 'screen font anti-aliasing' in OpenOffice.
    The original post is here:
    http://ubuntuforums.org/showthread.p...24#post6230724
    Thank you very much.
    Please do not make duplicate threads on the same issue. Threads merged.

  10. #10
    Join Date
    Nov 2008
    Location
    Brazil
    Beans
    309
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: No letters appear in OpenOffice programs.

    I opened another thread because it's a separate issue and one would never guess seeing the title of this thread. Also I didn't close this one cos when I get this fixed I can post how I did it. And could you pls tell me if what I did is correct to change the xorg.conf file? If yes ,I'll have to search another solution ..

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •