Results 1 to 2 of 2

Thread: Sharing folder

  1. #1
    Join Date
    Jul 2005

    Sharing folder

    I use Ubuntu under VirtualBox. I've just upgraded from Ubuntu 8.04 to Ubuntu 8.10, and now the folder sharing isn't working. When I use
    sudo mount -t vboxsf share /home/lse/share ,
    I get the message /sbin/mount.vboxsf: mounting failed with the error: No such device .

    When I type "sudo modprobe vboxvfs", I get the message

    FATAL: Error inserting vboxvfs (/lib/modules/2.6.27-7-generic/updates/dkms/vboxvfs.ko): Unknown symbol in module, or unknown parameter (see dmesg)

    Does someone know how to solve this?
    Thank you!

  2. #2
    Join Date
    Jun 2006
    Washington State
    Ubuntu 10.04 Lucid Lynx

    Wink Re: Sharing folder

    I ran into the same problem. After receiving the same error message I tailed /var/log/syslog for more info. It appears that the vboxadd module is not being built properly by dkms; vboxvfs is unable to access symbols in the vboxadd module.

    I was able to work around the problem by building the kernel modules without dkms. I just removed the dkms package using apt. But I imagine you could also temporarily rename dkms or move it from the PATH. Then rerun the guest additions installer and reboot.

    Without dkms, you will need to rebuild the modules whenever the kernel is updated. But at least you can share your files.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts