Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: World of Warcraft, Intrepid Ibex, Sound/FPS issues.. How to fix it!

  1. #1
    Join Date
    Nov 2006
    Location
    Ontario, Canada
    Beans
    32
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Smile World of Warcraft, Intrepid Ibex, Sound/FPS issues.. How to fix it!

    Greetings fellow Azerothians...

    I, much like most other people in the Ubuntu community, recently upgraded my computer from 8.04 to 8.10. I am extremely impressed with 8.10 thus far, with one exception:

    MY WARCRAFT DOESN'T WORK!!! I am practically addicted to warcraft, and I had a wicked problem with the sound and video. My sound was extremely static-y, and my fps dropped from 25-30 to 6 overnight. The only thing I had changed was Ubuntu, the upgrade.

    Contrary to what other information I have found, it seems that the issue isn't related to PulseAudio at all, rather the wine update that ships with Intrepid Ibex. Therefore, I will explain how to get back to a running warcraft, without removing Intrepid Ibex.

    1) Open synaptic package manager.
    -Search for wine.
    -Mark for removal. (Not complete removal, just removal.)

    2) Open the following web page:
    -http://wine.budgetdedicated.com/archive/index.html
    -Click on Wine 1.1.5 i386 (for 32-bit) or Wine 1.1.5 amd64 (for 64-bit)
    -I know it is not for "Intrepid Ibex" and is for Hardy Heron. This is the one that I used, and seemed to work in my case.
    -Open with GDebi.

    3) GDebi will install and compile wine for you.

    4) Your warcraft should now work properly.

    This fix I am posting as it worked perfect for my computer: HP Pavilion a1330n: AMD 64 bit processor, BFG nVidia 8400 GS, 1 mb ram.

    I just thought I'd add this, as I could find absolutely no fixes for warcraft as of yet.

    Thumper
    Thumperox of Rexxar.
    Thumper

  2. #2
    Join Date
    Jul 2008
    Location
    Columbus, Ohio
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: World of Warcraft, Intrepid Ibex, Sound/FPS issues.. How to fix it!

    I haven't tested this but i have to point out that there should (As in it worked for me.) be a better way. I changed my Audio settings to OSS (May work with Alsa now, Haven't tested it.), Hardware acceleration to Standard and Driver Emulation unchecked works great. I even got about 15-20+ More FPS for that. ^_^
    Bios Elemental - My Blog | Useful Ubuntu and WINE related help as well as general Geek Things.

  3. #3
    Join Date
    Jun 2008
    Beans
    6
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: World of Warcraft, Intrepid Ibex, Sound/FPS issues.. How to fix it!

    Switching to OSS does fix the sound stuttering issue. (ALSA still sounds terrible with the other setting changes). The problem with using OSS is that only 1 program has access to the sound driver at a time. This means I can't use Ventrilo (voice chat) while raiding in WoW.

  4. #4
    Join Date
    Jul 2008
    Location
    Columbus, Ohio
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Talking Re: World of Warcraft, Intrepid Ibex, Sound/FPS issues.. How to fix it!

    Quote Originally Posted by wbrucem View Post
    Switching to OSS does fix the sound stuttering issue. (ALSA still sounds terrible with the other setting changes). The problem with using OSS is that only 1 program has access to the sound driver at a time. This means I can't use Ventrilo (voice chat) while raiding in WoW.
    Thus why you use aoss to lauch WoW via wine. My blog has some info on it as well but basically launch WoW like this.

    Code:
    aoss wine WoW.exe
    Bios Elemental - My Blog | Useful Ubuntu and WINE related help as well as general Geek Things.

  5. #5
    Join Date
    Oct 2006
    Location
    Pittsburgh, PA
    Beans
    69
    Distro
    Ubuntu

    Re: World of Warcraft, Intrepid Ibex, Sound/FPS issues.. How to fix it!

    Thanks Thumper. That made my sound much better. Video still lags, but thats life with a gf5200.

  6. #6
    Join Date
    Jun 2008
    Beans
    6
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: World of Warcraft, Intrepid Ibex, Sound/FPS issues.. How to fix it!

    I tried using AOSS, but I still can't get both WoW and Ventrilo both active with sound.

  7. #7
    Join Date
    Nov 2006
    Beans
    Hidden!

    Re: World of Warcraft, Intrepid Ibex, Sound/FPS issues.. How to fix it!

    how would i get Hardware acceleration to Standard and Driver Emulation unchecked?

    ya its prollay a real nub question, but im getting 4 fps in BT, which is no good

  8. #8
    Join Date
    Nov 2008
    Beans
    41

    Re: World of Warcraft, Intrepid Ibex, Sound/FPS issues.. How to fix it!

    This works if you are using 1.1.7. if any other it still might work if you have ever installed 1.1.7.
    First you'll have to get rid of your current wine so do that.
    System > Administration > Synaptic packet manager, there find wine and check complete removal, then go to home folder (Places > Home folder) btw the folder is hidden so turn show hidden folders on and delete your .wine folder (you might want to backup your games & apps and other stuff you have installed under wine from that folder as when you delete it they will be lost unless backuped)
    Then remove every single thing related to your wine in the Software sources(System > Administration > Software sources)
    Now all you have to do is install wine from your Add/Remove apps in Applications tab and voila you should have normal sound once again tought do not upgrade it to 1.1.7 let it stay 1.0.1.
    Last edited by Trap3d; November 3rd, 2008 at 08:22 PM.

  9. #9
    Join Date
    Oct 2007
    Beans
    5

    Re: World of Warcraft, Intrepid Ibex, Sound/FPS issues.. How to fix it!

    Thumper13's instructions worked like a charm

    Synaptic Package Manager->Search Wine->Remove Wine 1.1.7 (NOT complete)
    Download 1.1.5 .deb
    Install
    Play
    w00t

  10. #10
    Join Date
    May 2008
    Location
    Michigan
    Beans
    38
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: World of Warcraft, Intrepid Ibex, Sound/FPS issues.. How to fix it!

    I did the same as Amannim except after doing a base removal of 1.1.7, Synaptic came back showing 1.0.1 available for download, so I marked that one for installation. After waiting a few minutes for it to download, it was good to go. Wow works fine for my standards. I'm sure 1.1.5 has some nice updates but this method was a quick fix for those short on time.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •