Results 1 to 10 of 42

Thread: HOWTO: Far Cry 2

Threaded View

  1. #1
    Join Date
    Apr 2007
    Ubuntu 10.10 Maverick Meerkat

    HOWTO: Far Cry 2

    HowTo: Far Cry 2

    The installation went smooth. I just loaded up Far Cry 2 within the explorer "wine explorer /desktop=..." (wine explorer /desktop=Far_Cry_2,1440x900 setup.exe) and I did not install PunkBuster or Desktop Shortcut. The game may work with PunkBuster and Desktop shortcut, but I haven't tested that and I wanted to make sure the installation and the basics of the game worked first.

    Then I loaded up the game, (wine explorer /desktop=Far_Cry_2,1440x900 /home/USR/.wine/drive_c/Program\ Files/Ubisoft/Far\ Cry\ 2/bin/FarCry2.exe) and I got a few errors about missing dlls. And those are: d3dx9_38, gdiplus, iphlpapi, psapim, and xinput1_3. So I applied them to them to the bin folder and I also applied a No-CD Patch because of SecuROM. But After that, I loaded up Far Cry 2 again and it worked.

    Shorten Version:

    cd /media/cdrom0/ && wine explorer /desktop=DEFAULT,1440x900 setup.exe
    Untick PunkBuster and Desktop Shortcut
    use default installation path "Program Files/Ubisoft/Far Cry 2/"

    After installation, use the dll files I uploaded within this thread "FarCry2.HOWTO.TheDLLp1.tar.gz" & "FarCry2.HOWTO.TheDLLp2.tar.gz".
    and extracted them to the bin folder:

    cd /home/USR/Desktop/
    tar xvf FarCry2.HOWTO.TheDLLsp1.tar.gz && tar xvf FarCry2.HOWTO.TheDLLsp2.tar.gz
    Extract the dll file form "" to the "TheDlls" folder
    cd TheDLLs && mv * /home/USR/.wine/drive_c/Program\ Files\Ubisoft/Far\ Cry\ 2/bin\
    Load the Game:
    cd /home/USR/.wine/drive_c/Program\ Files/Ubisoft/Far\ Cry\ 2/bin && wine explorer /desktop=Far_Cry_2,1440x900 FarCry2.exe
    Within the Regedit:
    wine regedit


    - FarCry2.exe
    Make sure you are loading FarCry2.exe not the FC2Launcher, because the launcher isn't working at the moment.
    - Video Drivers are too old
    I get this error "Your Video Drivers are too old..." when loading FarCry2.exe. I hit OK and it loads the game. I am unsure on how to fix this yet.

    PS: I will continue to update this thread to fix any issues and slowness with the Game.

    Nvidia Card - 7700 GO
    Wine 1.1.4 (Not Compiled)
    Ubuntu Hardy Heron
    Gnome i386

    As always,
    Attached Images Attached Images
    Attached Files Attached Files
    Last edited by Sugi; October 27th, 2008 at 05:45 PM.
    WINE: Super Meat Boy // Far Cry 2 // Lineage 2
    VirtualBox: Snapshots // OSE Issues

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts