Results 1 to 8 of 8

Thread: [SOLVED] OpenOffice 3 Recovery Crash Fix!

Threaded View

  1. #1
    Join Date
    Apr 2007
    West Coast USA
    Ubuntu 8.10 Intrepid Ibex

    [SOLVED] OpenOffice 3 Recovery Crash Fix!

    After going around and around in the document recovery loop/crash with the newest OpenOffice (3), I have decided to document my steps and post the resolution in hopes that it will help many of our Linux brethren

    I went through the following:
    Completely uninstalled OpenOffice 2 and the installation of OpenOffice 3
    I installed OpenOffice 3 (sudo dpkg -i *.deb) from within the DEBS folder
    I then installed desktop integration from the desktop-integration folder

    I renamed .openoffice.org2 to openoffice.org2.backup

    I deleted the Recovery.xcu file

    I did: OOO_FORCE_DESKTOP=gnome

    When I'd start OpenOffice from shell (soffice) and (soffice -writer), it immediately went right into Document Recovery mode and gave this output in Bash:
    terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'
    terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

    I also had made sure that the .openoffice and .openoffice2 folders were not owned by root

    Finally, I found this post:

    I followed the instructions (deleted folder and renamed .openoffice.org2.backup back to .openoffice.org2)

    *note that these folders are hidden by default in your home directory, so once you're there just press control+h to show the hidden files

    Works like a charm now.


    Hope this helps some people!
    Last edited by randy78; October 15th, 2008 at 09:03 AM. Reason: Clarification
    Helping people crawl out of their Windoze...
    Please read THIS before asking if Anti-Virus and Firewalls are needed.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts