Hello,
I'm new to the Ubuntu world. I am reviving an old Kayak XU desktop with a 450 MHz processor and 8 G SCSI drive (yes, it's old). To put less load on the box, I installed Xubuntu 8.04 since it has a lighter desktop. I plan to use this box to teach myself web development,
I installed LAMPP, and it worked immediately. I was able to browse to http://localhost/xampp/index.php with no problems.
I ran a few sessions with no security set for mysql, ftp, etc.
Tonight I am having a problem, in that all of a sudden I can't browse to anything on localhost unless the network cable is plugged in. Firefox tells me it's in Offline mode. I sometimes plugged the LAN cable prior to this to browse out to the web, but with no problems accessing sites under my htdocs directory if it was unplugged.
Could this be a security problem? Did I get hacked? When the network cable was plugged into the box, I heard the hard drive start to grind away so I unplugged it.
Apache, mysql, etc are up and running when this occurs.
Can anyone help me? I'd like to avoid a complete re-install.

thanks,
KC