Results 1 to 10 of 810

Thread: Compiz-Check -- no more "Desktop effects could not be enabled"

Threaded View

  1. #11
    Join Date
    May 2008
    Ubuntu 10.10 Maverick Meerkat

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Woohooo, that's interesting.
    As Furlong suggested, I ran it allagain, and here it comes:
    wojciech@inspiron:~/programs$ ./compiz-check
    Gathering information about your system...
     Distribution:          Ubuntu 8.04
     Desktop environment:   GNOME
     Graphics chip:         ATI Technologies Inc M52 [Mobility Radeon X1300]
     Driver in use:         fglrx
     Rendering method:      AIGLX
    Checking if it's possible to run Compiz on your system...
     Checking for texture_from_pixmap...               [ OK ]
     Checking for non power of two support...          [ OK ]
     Checking for composite extension...               [ OK ]
     Checking for FBConfig...                          [ OK ]
     Checking for hardware/setup problems...           [ OK ]
    And compiz --replace yields:
    wojciech@inspiron:~/programs$ compiz --replace
    Checking for Xgl: not present.
    Detected PCI ID for VGA: 01:00.0 0300: 1002:7149 (prog-if 00 [VGA controller])
    Checking for texture_from_pixmap: not present.
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: present.
    Checking for non power of two support: present.
    Checking for Composite extension: present.
    Comparing resolution (1280x800) to maximum 3D texture size (4096): Passed.
    Checking for nVidia: not present.
    Checking for FBConfig: present.
    Checking for Xgl: not present.
    /usr/bin/compiz: line 407: /usr/local/bin/compiz: No such file or directory
    Some time ago, I also tried to run Xgl by brutal-force, i.e. by linking... er.. what was it... I guess I linked /etc/X11/X to /usr/bin/Xgl like it was suggested in this antique post.
    I know that its an anachronic way, but what a hell. If nothing else works.
    Effect was such that (of what I could say by looking at cpu monitor) it rendered some compiz-ian effect through one of my cpu's cores. I mean I could see some shadows cast by the windows, but no cube, nor another compiz stuff.
    Once more: I'm not sure if I said it before - about half a year ago, I guess it was the era of Gutsy, I had a working setup for compiz - I ran separate session with Xgl, chose it in gdm. But this stopped working when Hardy arrived.
    I guess that if I reinstalled Hardy from scratch, I wouldn't have the problems, but I dont wanna.
    Last edited by airborne_rodent; June 1st, 2008 at 10:59 AM. Reason: Addition of something new:)

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts