Results 1 to 3 of 3

Thread: Promiscuous mode doesn't seem to work

  1. #1
    Join Date
    May 2008

    Promiscuous mode doesn't seem to work

    Hi, I have done some research in this but don't seem to be getting anywhere.

    I have a Dell e1505 running the Broadcom 43xx Chipset driver(Restricted not NDISWrapper). It's got a 1390 WLAN minicard which works wonderfully, so does the wired card.

    This is a fresh install of Ubuntu and everything works, but when I use Wireshark and Driftnet, it doesn't seem to go into promiscuous mode.

    Driftnet shows only what I browse, Wireshark shows no HTTP traffic other than from this PC, but shows CUPS, ARP, etc. from other PCs.

    I have tried putting my wireless(eth1) into promiscuous mode with:

    sudo ifconfig eth1 mode promisc
    I have changed the modes to monitor as well with:

    sudo iwconfig eth1 mode monitor
    Anyway, I messed around with the modes and read up a little about iwconfig but nothing seems to have any effect.

    I saw a few sites claiming that the broadcom driver supports promiscuous mode, so I think I'm okay there.

    Anyway, that's where I'm at.

    Any help is appreciated.

  2. #2
    Join Date
    Feb 2006
    San Antonio
    Ubuntu 10.10 Maverick Meerkat

    Re: Promiscuous mode doesn't seem to work

    Have you tried running Kismet?

    It will kick your card into prom off the bat.
    Josh Beck
    Northeast Independent School District
    KSAT (Krueger School of Applied Technologies)

  3. #3
    Join Date
    May 2008

    Re: Promiscuous mode doesn't seem to work

    Thanks, I haven't. I'll give that a whirl. The only thing is that Wireshark and Driftnet are both set to promisc mode when I have been running them, but I'll try Kismet too.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts