Results 1 to 10 of 63

Thread: HOW-TO: Hardy on Motion Computing M1300

Threaded View

  1. #1
    Join Date
    Dec 2005
    Ubuntu 10.04 Lucid Lynx

    HOW-TO: Hardy on Motion Computing M1300 (Updated for Intrepid)

    So, I finally solved this thing (had been at it for at least a couple of months) so I'll just post here exactly how to do it. Most of the steps are similar to the ones on this thread, so much of this guide will be a copy-paste of that.

    1. Go to the terminal and install all of these
    sudo apt-get install setserial wacom-tools xserver-xorg-input-wacom
    2. Map the hardware port to a virtual serial port
    sudo setserial /dev/ttyS0 port 0x0238 irq 4 autoconfigure
    3. Check that all is working; first type
    wacdump -f tpc /dev/ttyS0
    and move your pen around the screen. If the numbers move, keep going. If they don't you're out of luck.

    4. Put the appropriate entries in the xorg file. type
    sudo gedit /etc/X11/xorg.conf
    , and paste these lines in there somewhere (I put them at the beginning)
    Section "InputDevice"
    Driver "wacom"
    Identifier "stylus"
    Option "Type" "stylus"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/ttyS0"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    Option    "Button2"    "3"
    Section "InputDevice"
    Driver "wacom"
    Identifier "eraser"
    Option "Type" "eraser"
    Option "Device" "/dev/ttyS0"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    Section "InputDevice"
    Driver "wacom"
    Identifier "cursor"
    Option "Type" "cursor"
    Option "Device" "/dev/ttyS0"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    and then add these lines to the Section "ServerLayout":
    InputDevice "cursor" "SendCoreEvents"
    InputDevice "stylus" "SendCoreEvents"
    InputDevice "eraser" "SendCoreEvents"
    4.1. (Optional for screen rotatiOn in step 8 ). Add these lines to the "Device" section:
    	Option		"RandRRotation"	"on"
    	Option		"NvAGP" 	"1"
    	Option		"DRI"		"false"
    WARNING:This last line will disable3D acceleration but i'ts neccesary.
    Click the save button and close gedit.

    5. Make these changes permanent by typing
    sudo dpkg-reconfigure setserial
    and selecting the option "autosave once"

    6. Restart and it should all be working!

    After this my tablet worked just fine, but the other guides included this last step so I'll post it here as a "last resor" measure.

    7. Type
    sudo xsetpointer stylus
    I actually don't know what this command is for, so if someone were to illuminate me...

    I know there aren't a lot of M1300 users out there but still I wish when I bought mine there was a guide just like this one to set it up.
    This is working for hardy but presumably it would work with future versions as well.


    All right, so Intrepid is here, so here is what needs to be done differently in order to setup the wacom tablet.
    • Replace step 4 in these instructions for the ones in this post

    • For screen rotation, just follow the usual steps (in the next post)

    • For screen brightness, the steps described 2 posts from this one are no longer necessary. Just add the screen brightness applet to the gnome panel and it should Just Work

    Got the battery problem solved. Follow these instructions

    trainerjonathan located the thread where there are instructions to get an onscreen keyboard at login
    Quote Originally Posted by trainerjonathan View Post
    By the way the instructions to add the on-screen keyboard to the login screen in this post worked perfectly for me.
    __________________________________________________ ______
    List of Tablet PC's working with Linux and links to the how-to's
    Last edited by priegog; March 12th, 2009 at 10:28 PM. Reason: Added OSK link

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts