Results 1 to 5 of 5

Thread: Hardy Upgrade caused apt problem

  1. #1
    Join Date
    Nov 2007
    Beans
    9
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Hardy Upgrade caused apt problem

    I have just upgraded to Hardy from Gutsy on my 64 bit system. I had alamin-server installed previously (to send SMS messages) - now Synaptic wont work, apt wont work, producing an error
    E: alamin-server: subprocess post-removal script returned error exit status 1
    I've tried to remove this package with apt-get remove; apt-get -f remove; dpkg -r alamin-server; all produce errors :

    Removing alamin-server ...
    chown: cannot access `/var/run/alamin': No such file or directory
    dpkg: error processing alamin-server (--remove):
    subprocess post-removal script returned error exit status 1
    Errors were encountered while processing:
    alamin-server
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    Right now I cant install or remove any packages - the rest of the system works fine though.

  2. #2
    Join Date
    May 2007
    Location
    UK near Bedford
    Beans
    3,483
    Distro
    Ubuntu Development Release

    Re: Hardy Upgrade caused apt problem

    Can you use sudo

    Code:
    sudo <any command here>
    does it return an error?

    PC

  3. #3
    Join Date
    Nov 2007
    Beans
    9
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Hardy Upgrade caused apt problem

    Yes I can sudo firefox no problem.

  4. #4
    Join Date
    Jun 2006
    Beans
    13

    Re: Hardy Upgrade caused apt problem

    same issue. alamin errors when apt-get:


    chown: cannot access `/var/run/alamin': No such file or directory
    dpkg: error processing alamin-server (--remove):
    subprocess post-removal script returned error exit status 1
    Errors were encountered while processing:
    alamin-server
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    have no idea why it's trying to --remove

    dboy

  5. #5
    Join Date
    Jun 2006
    Beans
    13

    Re: Hardy Upgrade caused apt problem

    Ok, easy fix:

    sudo touch /var/run/alamin

    apt-get update


    dboy

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •