I am having strange problems since upgrading to Hardy yesterday.

Every time I start up, X starts in low graphics mode.
My graphics card is an Nvidia 6800.
Using the nvidia driver in the setup dialog fails the test. Only the nv driver passes. But still it starts in low resolution.
After X has started and log in, I go through Screens & Graphics and choose the nv driver and correct monitor once more. Now with ctrl-alt-bckspace it starts with 1680x1050 resolution as it should. The restricted driver is enabled and in use. Yet I cannot enable compiz (Desktop effects could not be enabled), manually running compiz returns

Checking for Xgl: not present.
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity

and there is still the restart issue. When I restart it goes back to low resolution.

I reinstalled nvidia-glx-new in case something got wrong.
I tried using EnvyNG which returned no errors but still didn't work.
There are two other things to mention, not directly related but might indicate that the upgrade process was not successful.
The Grub menu did not get updated (it still shows 7.10 with 2.6.22-14 kernel) and uname -r returns 2.6.22-14-generic.
Running update grub returns:

Found kernel: /boot/vmlinuz-2.6.24-16-generic
Found kernel: /boot/vmlinuz-2.6.22-14-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

but I don't see 2.6.24-16 in any menu entry of the grub menu on startup
I know I can edit menu.lst and it should be added, but not being there and update not adding it is some kind of problem indicator.

Thank you all in advance,
Jason