Results 1 to 7 of 7

Thread: problems configuring mythbackend

  1. #1
    Join Date
    Nov 2007
    Beans
    11

    problems configuring mythbackend

    hi

    i installed mythbuntu on an htpc. when i try to configure the backend i get this error message:
    sudo mythbackend
    [sudo] password for netlord:
    2007-11-15 21:04:26.135 Using runtime prefix = /usr
    2007-11-15 21:04:26.149 New DB connection, total: 1
    2007-11-15 21:04:26.150 Unable to connect to database!
    2007-11-15 21:04:26.150 Driver error was [1/2003]:
    QMYSQL3: Unable to connect
    Database error was:
    Can't connect to MySQL server on 'mediacenter' (111)

    QSqlQuery::exec: database not open
    QSqlQuery::exec: database not open
    2007-11-15 21:04:26.200 DB Error (KickDatabase):
    Query was:
    SELECT NULL;
    No error type from QSqlError? Strange...
    2007-11-15 21:04:26.251 Failed to init MythContext, exiting.
    as i had seen on another thread i tried to access the mysql database. this works whitout a problem.
    i can connect to the mythconverg database and i can see the 75 tables.

    what else its going wrong?

  2. #2
    Join Date
    Dec 2004
    Location
    Cheshire, UK
    Beans
    256
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: problems configuring mythbackend

    Hi,

    I'm assuming the database server is on the same machine as the backend.

    You probably need to do a 'sudo dpkg-reconfigure mythtv-common' and answer the questions. If my assumption above is correct, you can use 'localhost' as the name / IP of the machine running MySQL, accept the rest as defaults. You'll need to supply the password which was randomly generated when MythTV was installed.. If you don't have it, you might need to change the MySQL password for the MythTV user...

  3. #3
    Join Date
    Nov 2007
    Beans
    11

    Re: problems configuring mythbackend

    hi

    your assumption is right. the back- and the frontend are on the same machine

    i tried your tip, using the password from /etc/mythtv/mysql.txt, and i got no error message.
    but when i try to start the mythtvbackend i get the same error message as before.

    what else can i do?

    cu
    netlord

  4. #4
    Join Date
    Dec 2004
    Location
    Cheshire, UK
    Beans
    256
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: problems configuring mythbackend

    Hmm, strange..

    How are you trying to start the backend configuration?

  5. #5
    Join Date
    Jan 2007
    Location
    CA
    Beans
    846
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: problems configuring mythbackend

    have you tried 127.0.0.1 as the backend IP or just localhost?

  6. #6
    Join Date
    Oct 2005
    Location
    Austin, TX
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: problems configuring mythbackend

    don't start the backend that way.

    Code:
    sudo /etc/init.d/mythtv-backend restart

  7. #7
    Join Date
    Nov 2007
    Beans
    11

    Re: problems configuring mythbackend

    Quote Originally Posted by kevinatkins View Post
    Hmm, strange..

    How are you trying to start the backend configuration?
    via sudo mythbackend

    Quote Originally Posted by OffAxis View Post
    have you tried 127.0.0.1 as the backend IP or just localhost?
    i tried both. none worked...


    Quote Originally Posted by superm1 View Post
    don't start the backend that way.

    Code:
    sudo /etc/init.d/mythtv-backend restart
    i´ll try this.

    and the i´ll report

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •