Results 1 to 10 of 10

Thread: Howto: Open Sound System in ubuntu feisty

Threaded View

  1. #1
    Join Date
    Dec 2006

    Howto: Open Sound System in ubuntu feisty

    First thing first:
    Why should I use OSS instead of ALSA? Alsa is far more superior!

    Well thats simply not true. OSS has evolved, now it is open source ->
    and what most important, sound on my sound blaster live card (7 yers old I would say) is amazing. Twice as good as with ALSA. ALSA simply didn't manage to get my bass boost, and proper loudness. It always start cracking and make noises. I can use external amplifier for that but for headphones it is overkill. And why my 200$ card (7 years ago) behave as some cheap, crappy one?

    With OSS sound is simply amazing. That's why I'm writing this howto, so others could have proper sound under linux, you are worth it

    Dificulty level: intermediete - advanced i would say (one simple compile required - many thing could not work as previously, so you are willing to experiment.
    EDIT: I will try on gutsy soon
    Enviroment: Fesity Fawn, i386, kernel 2.6.20-16, kubuntu (should work in ubuntu as well - but I cannot guarantee - I do not know if gnome server can use oss - probably it can - I can confirm it can)

    What will work: Sound under kde, sound in xine, kaffeine, amarok. Sound in flash in your browser
    Problems: flash in firefox seems to block sound system. Not like this happend on alsa too? (at least in 6.10)
    I'm only using this since yesterday, so perhaps more things will be broken or sth

    What will not work
    : Skype - I was not able to get it working, nor in flash 1 .4. and 1 .3 - perhaps I did not tried enough hard

    So let's get started:

    First we install prereqrusites:

    sudo apt-get install linux-headers-generic linux-source build-essential
    Then we go to the oss website and download oss:

    We choose linux 2.6 - deb - x86 (or amd if your are running 64 bit)

    Once downloaded we install it with right click, Kubuntu package menu - > install package

    Instalation will compile modules, find our sound card, and try to make it active.
    On my machine last phase didnt worked out as alsa modules cannot be unloaded as they were in use. Restart did help. Only OSS modules came up.
    If alsa were starting somehow still, remove any refrences to alsa in /etc/rc.dX and/or blacklist appropriete modules.

    So now OSS modules work, but still we don't have sound.

    Go to KDE Control center to the sound system, hardware: and choose OSS (automatic detection should work as well)
    Sound shoud work. In Amarok you do the same: change output from alsa to oss - it is in the config: amarok -> module -> output plugin.

    Now there are only two problems to work out: Kmix didnt start, and flash wont play sound.

    First KMix:
    OSS just overwrite library, that KMix is not able to work with. We need to preload old lib
    LD_PRELOAD=/usr/lib/ kmix

    Then Kmix should work. There were not so many options compared to alsa, and perhaps diffrent layout.

    Try start ossxmix and there you can adjust almost everthing (my favorite bass bost for the headphones

    If you have many soundcards (that was my case) try:
    ossinfo -x
    and then
    ossxmix -dX
    where X is number of the card you would like to adjust.

    Okay, so nowe everything but flash movie works.

    There you find manual and source file, manual was kind off so thats how I did this:

    go to the file and comment OPENSSL on line 52:
    make sure it looks like this:
    [lines between 52 and 56]
    //#define OPENSSL
    //#define GNUTLS
    //#define ALSA
    #define OSS
    //#define V4L1
    Alternativly just find openssl dev package, which in ubuntu repo I was unable to find. I do not need ssl anyway.

    So when your are done with hacking sources in this directory where sources are do:
     cc -shared -O2 -Wall -Werror flashsupport.c -o
     sudo cp /usr/lib
    Done, flash sound should work!

    I've upgraded to gutsy and I'm still on alsa here so I can only guess that you should remove start script in /etc/rc2.d
    It is called oss or something like that.

    It is end of the how-to. Many things could go wrong, I've just installed this yesterday, but suffice to say I thnik I will never use alsa again. Sound quality with OSS is simply twice as good, and I do not want my SB Live card play like some cheap software s***

    Feedback is welcome - i will update how to accordingly.

    I really hope ubuntu will change from alsa to oss some time for now. In my opinion it is right way. People dont like when they hardware works bad under linux.
    Last edited by Akre; October 25th, 2007 at 07:43 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts