Results 1 to 10 of 543

Thread: HOW TO: Install Ubuntu on a HP TC1100 tablet pc

Threaded View

  1. #1
    Join Date
    Feb 2007
    Ubuntu Development Release

    HOW TO: Install Ubuntu on a HP TC1100 tablet pc

    I just bought a 2nd hand HP TC1100 tablet pc, and have to say, I'm impressed. It came with a docking station (although I don't have much use for it), with a DVD/CDRW drive which can be removed and placed in an external USB caddy. I'd say this is one of the better designed tablets around (I also have a Fujitsu ST4110).

    Ok. Down to business. This is what I have so far, and will keep this guide updated as more information arrives.

    Ubuntu 7.04

    After installing, everything pretty much works out of the box.

    Enable the NVIDIA driver from the Restricted Drivers Manager.

    Then you need to update the xorg.conf file:
    sudo nano /etc/X11/xorg.conf
    Edit the Device section and add:
    Option    "RandRRotation"    "on"
    Option     "NvAGP"     "1"
    This enables rotation capabilities. The 2nd line is to help suspend work properly.
    Then edit the InputDevice section- Driver wacom - Identifier stylus add:
    Option    "Button2"    "3"
    This enables right-clicking with the pen button.

    You will need to install wacom-tools:
    sudo apt-get install wacom-tools
    You will need a script and map it to a key. The script:
    # Change System Input orientation for Tablet Mode
    # Depends on wacom-tools from repo
    orientation=`/usr/bin/xrandr --query | /bin/grep "Current rotation" | /usr/bin/awk '{print $4}'`
    if [ "$orientation" = "normal" ]; then
    	/usr/bin/xrandr -o left
    	/usr/bin/xsetwacom set stylus Rotate CCW
    	/usr/bin/xrandr -o normal
    	/usr/bin/xsetwacom set stylus Rotate none
    Save it as and put into the /usr/bin/ directory. The TC1100 has a 'Q' key on its edge. In Windows, this activates a popup menu, but the menu doesn't exist in Ubuntu. So we will use it for screen rotation. To map the key, open the Configuration Editor and browse to /apps/metacity/keybindings_commands. Edit command_1 (or the 1st available command) enter: sh /usr/bin/ . Then browse to /apps/metacity/global_keybindings and edit the run_command_1 with 0x9f (or press the 'Q' button.

    OSK: On Screen Keyboard
    Cellwriter version 1.2.5 is the choice here for both OSK and hand-writing recognition. Under System>Preferences>Accessibility>Assistive Technology Preferences, you need to check the following:
    Enable assistive technologies
    Password dialogues as floating windows (the on-screen keyboard can be used for root access)
    Start on-screen keyboard at log in

    I did find a problem with the pen operating erratically during login where the cursor would not follow the pen and kept jumping to the lower-right of the screen. To stop this behaviour, uncheck 'Enable accessible login' in System>Administration>Login Window - Accessibility tab. This is probably a bug in the wacom driver.

    To enable Cellwriter at login:
    sudo nano /etc/X11/gdm/Init/Default
    At the bottom of the script, add:
    cellwriter --keyboard-only --window-y=600 &
    ... so it reads ...
    cellwriter --keyboard-only --window-y=600 &
    exit 0
    If you wish to use xvkbd at login instead:
    sudo apt-get install xvkbd
    ... then enter ...
    xvkbd -geometry -300-100 -no-keypad &
    ...or onboard:
    sudo apt-get install onboard
    ...then enter...
    onboard &
    ... into the /etc/X11/gdm/Init/Default file instead of cellwriter.
    Kubuntu users: Put either onboard or xvkbd into the /etc/kde3/kdm/Xsetup file.
    Also note: Login style must be changed from Themed to Plain in System>Administration>Login Window - Local tab
    Another note: If you enable automatic login, do NOT amend this file as you will end up with 2 instances of the OSK!

    Sleep & Suspend
    To make sleep and suspend work, follow the instructions here

    To make the 3 pen activated 'soft keys' work, look here

    Since Cellwriter 1.3.1, it is possible to use it when the screen is locked. Open Configuration Editor and browse to apps/gnome-screensaver and check embedded_keyboard_enabled and enter:
    cellwriter --xid
    under embedded_keyboard_command

    Brigtness can also be adjusted. Look here
    That's about it.

    What doesn't work?
    The SD card reader -
    However, the PCMCIA slot DOES work, so I bought a Jessops branded '6 in 1' card reader for it and now I can use my SD card with this tablet. But I would prefer it if the built-in card reader worked.

    Everything else works or can be made to work in some fashion.

    Any other useful software?
    Xournal is an equivalent to Windows Journal.

    Ubuntu 7.10

    For those wanting to try Ubuntu 7.10 (Gutsy), I will say it works very well, but you won't get any better results than with 7.04 (Feisty). That is to say, what doesn't work with Feisty, still doesn't work with Gutsy. After installation, follow the above procedure.

    Suspend, hibernate, and sleep
    Although suspend and hibernate work fine, sleep only works once, and afterwards it may give this error:
    Your computer failed to suspend.
    ...even though it did it perfectly. It then (without any warning), goes into hibernation. When it wakes from that, another error message:
    Your computer failed to hibernate.
    ...even though it did it perfectly! If anyone knows the answer, please let me know.
    EDIT: After this error, you may lose your wireless connection and have to set it manually (related?).

    The console shows different output in Gutsy for xrandr, so the above script won't work correctly. Please use the following:
    if [ -n "$(xrandr | grep 768x1024)" ]; then
            xrandr -o normal
            xsetwacom set "stylus" Rotate NONE
            xrandr -o left
            xsetwacom set "stylus" Rotate CCW
    ...from post #16 by ronnystandtke. Thanks for that.

    Stylus not working? While you are editing /etc/X11/xorg.conf, you will need to uncomment one line at the bottom to make the Stylus work. You do not need to uncomment Eraser or Cursor.

    Compiz works quite well on this tablet considering the low-end video card and limited video RAM. Edit this file:
    sudo nano /usr/bin/compiz
    ...and comment out the line that reads:
    NVIDIA_MEMORY="65536" # 64MB read:
    # NVIDIA_MEMORY="65536" # 64MB
    This will allow you to start the desktop effects without it checking for a minimum of 64Mb of video RAM.
    You may notice the 3 stylus activated 'buttons' stop working with Compiz running. It's because it's tampered with the key mappings. You need to add the key mappings in the CompizConfig Settings Manager under General Options and add the commands in the Commands tab, and the key mappings in the Actions tab>Commands.
    Compiz is installed by default in Gutsy, so you just need the Settings Manager:
    sudo apt-get install compizconfig-settings-manager
    If you have the model with bluetooth like mine, I can tell you it works fine. I'm using a HP Deskjet 460wbt printer using the bluetooth module.

    Ubuntu 8.04

    I'm skipping Hardy Heron because it shouldn't be much different from Gutsy. There are posts here concerning Hardy if you do a search.

    Ubuntu 8.10

    For anyone using Ubuntu version 8.10 (Intrepid Ibis), refer to post 116 by Aearenda.
    Last edited by phenest; November 17th, 2008 at 10:32 PM. Reason: Add Ubuntu 8.10
    "Knowledge is power. Who said that?" - Dave Lister


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts