No, an edgy package won't work for dapper, as dependencies won't be satisfied.

You can download updated i386 binary packages for dapper, edgy and feisty from
http://wallyweek.altervista.org.

Please note you have to download the right .deb file for your ubuntu release,
and manually install it from console with
sudo dpkg --install <path_to_package-name-and_version>.deb.

I'm sorry, I'm still in the process of setting up a repository, which will be heasier to
use with apt-get or Synaptic. It's taking much time as I expected.

Cheers,
Cesare.