Results 1 to 10 of 218

Thread: How to: Xubuntu - Thunar Native Windows Network Browsing

Threaded View

  1. #1
    Join Date
    Jun 2006
    Xubuntu 6.10 Edgy

    How to: Xubuntu - Thunar Native Windows Network Browsing

    Since Thunar doesn't have native network Browsing, here is a good way to accomplish it:

    1) In XFCE's Applications -> System -> Shared Folders. (This should trigger a Samba install if you don't already have a share, and it should allow you to define the proper workgroup)

    2) Install fusesmb in Synaptic (from Universe repository)

    3) Edit /etc/modules and add the word 'fuse' to the modules list to be loaded (without quotes), and save the file.

    4) Reboot, so the fuse module loads, and the proper workgroup is read for samba.

    5) In XFCE Applications -> System -> Users and Groups... Properties of your username... User Priveleges Tab... check "Allow use of fuse file systems..."

    6) Create a directory that you are going to mount your network browse to... I used /media/network. Change permissions to read / write for group and others (777).

    *** 6.5) In a terminal, type: sudo chown <username>:fuse /media/network
    (Where <username> is your user account logon name)

    *** 6.6) Double check that the permission to use fuse took. Applications -> System -> Users and Groups... Manage Groups... find fuse and choose properties. Make sure your user name account is in that group and check-marked.

    *** 6.7) Reboot the system and triple check with step 6.6

    7) In XFCE Applications -> Settings -> Autostarted Applications... Add an application... name and describe as you wish... for command line, put: fusesmb /media/network (Or whatever mountoint you created).

    8) Open Thunar, and navigate to the parent folder of your mountpoint... then drag the 'mounpoint folder' to the places (shortcut) pane of thunar.

    9) Logout and log back in (So the user privilege and fusesmb autostart will take affect)

    *** Added steps to help prevent some access denied issues some people have been experiencing with fusesmb.

    My original thread on this topic is here:

    I hope this helps my fellow Xubuntu users... and I also hope that the Xubuntu team somehow enables something similar by default, or at least as an install option.

    Last edited by Tazix; March 4th, 2007 at 05:16 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts