Results 1 to 10 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

Threaded View

  1. #10
    Join Date
    Nov 2006
    Ubuntu 6.06 Dapper

    Re: Mount samba shares with utf8 encoding using cifs

    [quote]narky kicks himself in the head with a


    Thanks for your reply.

    I appreciate you filling me in on the background stuff, that learned experience stuff is impossible to get from a book and difficult to read between the lines on a howto.

    okay ... let's hope that the 4th times' to charm here. the touchpad driver keeps browsing backwards when i touch it
    Touche. My 'next' task is to find out how I can turn my laptop (Dell Inspiron 1150) touchpad off, when I buy a real mouse, it drives me nuts the way it does that.

    Okay it's official I'd like to cry. I've read all the man pages for mount, mount.cifs and mount.smbfs some of them several times. I have no idea why but the winning formula seemed to be:
    sudo mount -t cifs   // /media/music -o user=*****,password=*****,domain=*****
    Looking good... (see bottom line)
    /dev/hdc1 on / type ext3 (rw,errors=remount-ro)
    proc on /proc type proc (rw)
    /sys on /sys type sysfs (rw)
    varrun on /var/run type tmpfs (rw)
    varlock on /var/lock type tmpfs (rw)
    procbususb on /proc/bus/usb type usbfs (rw)
    udev on /dev type tmpfs (rw)
    devpts on /dev/pts type devpts (rw,gid=5,mode=620)
    devshm on /dev/shm type tmpfs (rw)
    lrm on /lib/modules/2.6.15-27-386/volatile type tmpfs (rw)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
    // on /media/music type cifs (rw,mand)
    /side note
    I think it also may have worked another time with the 'rw' switch I discovered it had worked once by accident (I reckon I almost tried every sort of switch combination/placement imaginable.) I still have no idea what the '-t' switch does.
    You were right to, when it gets mounted in 'media' it does show up on the desktop!

    And then:
    *dramatic pause* (see screenshot)
    There's nothing in it. #$%?!?!#!
    I don't think i've gotten anywhere at all.

    The following is from the mount.cifs 'man' page:
    In the directory /proc/fs/cifs are various configuration files and pseudo files which can display debug information...For more information see the kernel file fs/cifs/README.
    Well I had a look in the /proc/fs/cifs folder and I couldn't find any debugging stuff not in the debugging or FYI files anyway. I also couldn't find the 'README' file mentioned.

    To answer your questions:
    i assume you have this connected and transferring files with no problems to a windows client? if so, did you have to install software or drivers to make it work?
    I use it all the time on windows clients without a problem. You can just path to it as you would another windows machine (e.g. \\server-ip), there is a funny problem with windows where if you have the guest account turned on it won't ask you for a username and password so you can't access the drives. (And so, no I did not have to install any additional software; I have several of the drives loading as 'network' drives on boot up)

    So am I right in understanding that my router is linux based? Would presumambly run something similiar to SAMBA to give windows compatability and would recommend cifs for linux interfacing?

    how about firewall protection. you must have a router in place, so it's something worth checking.
    Hmm, everything does run behind a firewall/router. But then how different is cifs to smbfs and the nautilus sharing things. Because the files appear when I mount it with smbfs and I stream music with rhythmbox fine under nautilus, and I can path to it with smb://ip-adress/folder --> it's just a pity not all the programs (ie. Amarok) can interface in this way.

    What kind of thing would stop cifs from working? Do I need a port forward on the router or some such?

    since nfs is a completely different functionality for mounting shared files, the command in fstab and in the cli is completely different. so no, if you just use "mount" it does not assume nfs.
    But if I follow the instructions here:
    under "NFS Client"
    and the instructions for a manual mount:
    sudo mount /home/poningru/music
    -Then that does a nfs mount and they haven't added in any extra switches?

    the wins stuff at the beginning is designed to allow your ubuntu computer to resolve netbios names, so you will be able to mount your nas by name rather than ip.
    Hmm in the case I think the wins stuff worked because I can ping the server using it's DNS name rathern it's ip adress. (not sure if I used the right words then - hopefully you get my meaning)

    As requested, smbtree info:
            \\NARKY-LAPTOP                  narky-laptop server (Samba, Ubuntu)
                    \\NARKY-LAPTOP\ML-1510          ML-1510
                    \\NARKY-LAPTOP\ADMIN$           IPC Service (narky-laptop server (Samba, Ubuntu))
                    \\NARKY-LAPTOP\IPC$             IPC Service (narky-laptop server (Samba, Ubuntu))
                    \\NARKY-LAPTOP\print$           Printer Drivers
    So who knows why but the server isn't even showing up there. I don't think i've progressed at all, I think i'm going backwards.

    Attached Images Attached Images
    Last edited by narky; November 4th, 2006 at 08:44 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts