Results 1 to 9 of 9

Thread: in unity, how do I disable the window auto resize?

  1. #1
    Join Date
    Mar 2007
    Beans
    790

    in unity, how do I disable the window auto resize?

    Like, if I drag a window to the top of the screen, somehow this is supposed to mean I want the window full screen. Screw that if I wanted it full screen I'd have clicked the button on the top of the menu. Windows 7 does this too and it just as annoying.
    Registered Linux User: 450747 Registered Ubuntu User: 16269

  2. #2
    Join Date
    Jun 2007
    Location
    Minneapolis, MN
    Beans
    749
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: in unity, how do I disable the window auto resize?

    Code:
    sudo apt-get install compizconfig-settings-manager
    Code:
    ccsm
    Uncheck the "Grid" in the "Window Management" category.

    This will stop the window from maximizing when dragged to the top.

    The window will still maximize if it fills more than 3/4 of the screen. The fix for this will be in Oneiric.
    Moderation in all things; including moderation.

  3. #3
    Join Date
    Mar 2007
    Beans
    790

    Re: in unity, how do I disable the window auto resize?

    Thanks!!
    Registered Linux User: 450747 Registered Ubuntu User: 16269

  4. #4
    Join Date
    Jun 2009
    Beans
    14

    Re: in unity, how do I disable the window auto resize?

    Thanks a lot. That was annoying but now it works

  5. #5
    Join Date
    Sep 2007
    Location
    State College, PA
    Beans
    30
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: in unity, how do I disable the window auto resize?

    Thanks JRV! This is so much better.

  6. #6
    Join Date
    Feb 2008
    Beans
    20

    Re: in unity, how do I disable the window auto resize?

    Lifesaver! Cheers.
    Now I don't have to be afraid of my windows touching the edge of my screen.

  7. #7
    Join Date
    Aug 2011
    Beans
    1

    Re: in unity, how do I disable the window auto resize?

    Thanks for this fix. This issue was seriously starting to get on my nerves.

  8. #8
    Join Date
    Apr 2012
    Beans
    1

    Re: in unity, how do I disable the window auto resize?

    For the sake of completeness, in case you don't have root access to your box, you can stil go to

    System Settings->Desktop->Screen Edges
    and uncheck the option
    "Maximize windows by dragging them to the top of the screen"
    That did it for me (KDE 4.4.5, Ubuntu squeeze)

  9. #9
    Join Date
    Feb 2013
    Beans
    1

    Cool Re: in unity, how do I disable the window auto resize?

    Unity still does auto-site windows on my desktop even when disabling "grid".
    you have to uncheck "scale windows", too (in deutsch: "Fenster skalieren")
    otherwise it will still maximize the y-axis of the window when it touched the borders of the screen.

    who did make such things a default option in the first way?
    what a ridiculous fail.

    [edit] ok, i described it wrong, i guess.
    even after i unchecked "grid" some weeks before, ubuntu had a weird auto-resize activated on my desktop. this was just a "vertical" auto-resize. i just now got rid of it by checking some options in the window manager options screen in ccsm and then unchecking them again.
    what a pain.

    [edit2]
    no, didn't fix it at all.
    seems to be a bug still present in 12.10
    happens from time to time but i havent been able to reproduce it, i will try and fill in a bug report.
    Last edited by Lahmacun; February 28th, 2013 at 07:48 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •