Hey there everyone, I am new to Ubuntu and Linux in general. I have installed Ubuntu 12.10 from the official website. I am running dual boot with Windows 7. My machine is a laptop Lenovo G560.
At home I am getting Internet from a wireless router. I have no problems connecting to my wireless(did not install any drivers) but I can't seem to get wired connection working. When a plug the cable nothing happens, I do not get the usual arrows icon for wired connection. I get a message now and then about wired connection disconnected and nothing else. I have tried disabling/enabling wired/wireless connection and networking in general - nothing seems to work.
As I am pretty much a newbie with Linux I apologize in advance for any missing crucial information you need to help me solve this. Whatever additional info you need I will be posting.

p.s - I have tried to achieve wired connection at my friends house as well - same thing + wireless connects with no problem but there is no actuall Internet connection. Same thing happens in the dorm where I study and spend most of my time - cable doesn't work, wireless connects but there is no Internet.
It seems as if I get Internet signal only at home and only through wireless.
Windows 7 works fine everywhere.