Results 1 to 2 of 2

Thread: 12.04 "login loop" nvidia

  1. #1
    Join Date
    Nov 2012

    12.04 "login loop" nvidia

    About a week ago I had left my computer on at night so it could reinstall a game on steam overnight and I woke up the next morning to find that there was a power outage in the middle of the night (all the clocks not running on battery were messed up and my computer was off). When I tried to start up my computer, It asked me as usual which kernel I wanted to boot from and I selected the most recent version like I usually do and it went to the ubuntu loading screen. Then it got weird. Instead of taking me to the login screen as it would normally do, I got a command line telling me to login. I tried pressing CTRL+ALT+F7 but it didn't work, all I got were a whole bunch of lines of text in a command line. I went back to F1 and logged in and tried using 'startx' but it came up with a few errors and didn't start. after trying to reinstall my nvidia drivers (the last word being plural turning out to be the original problem), nvidia-experimental-304 and nvidia-experimental-310, I noticed when I used 'startx' that it mentioned the kernel nvidia version being that of the 304 not the 310, so I purged the 310,
    sudo apt-get remove --purge nvidia-experimental-310
    and when I rebooted it brought me to the login screen.

    Now for the current problem, I can't login to my user "kinetos". Whenever I enter my password my monitor goes black and when I move my mouse it just loops back to the login screen. When I go down to "Login" and enter "root" then my password it logs in to root, I get my root desktop like it should, and all my files are still on both my hard drives.

    I have read elsewhere that the problem is sometimes the fact that .Xauthority is claimed by root, and checking my permissions in /home/kinetos while logged in as root, I see that .Xauthority is in fact owned by root. Is this the problem? Do I need to set it to my other user? Are there any problems that would be caused by doing so?

    Thanks for the help!

  2. #2
    Join Date
    Nov 2012

    Re: 12.04 "login loop" nvidia

    I figured it out, root claimed my .Xauthourity file in home all I had to do was change it back with
    sudo chown kinetos:kinetos .Xauthourity
    and it hasn't messed up again yet!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts