Results 1 to 2 of 2

Thread: eGalaxTouch calibration does not work

  1. #1
    Join Date
    Jan 2013

    eGalaxTouch calibration does not work


    I am using a Samsung Touchscreen (LTI220MT02) at Ubuntu 12.04 with drivers from eGalaxTouch. Driver download from . As desktop manager I use lightdm.

    I want to calibrate the touchscreen, but so far I have no success, the calibration is still not working. I have tried the following:

    1) The 4-point-calibration tool 4Pts Cal from the eGTouchU programm (comes with the driver) is always displayed as inactive (cannot be clicked). See image eGTouchU.png attached. I want to execute the 4Pts Cal but this is not possible, I do not know why. I have read in forums that normally this tool should be executable. Does anyone know how to get 4Pts Cal working? Or does anyone know in which file and in which format the tool saves the calibration data?

    2) I have tried xinput_calibrator, the following output is shown:
    Section "InputClass"
    Identifier "calibration"
    MatchProduct "eGalaxTouch Virtual Device for Single"
    Option "Calibration" "43 2039 52 1959"
    In forums I have read to put this data not as shown by xinput_calibrator in /etc/X11/xorg.conf.d/99-calibration.conf but to put this data into /usr/share/X11/xorg.conf.d/99-calibration.conf . After reboot calibration still does not work. I have also tried to put the line
    Option "Calibration" "43 2039 52 1959"
    no success.

    3) I have tried to use xinput directly, xinput --list results in:
    Virtual core pointer                        id=2    [master pointer  (3)]
    Virtual core XTEST pointer                  id=4 [slave  pointer  (2)]
    DualPoint Stick                             id=15    [slave  pointer  (2)]
    AlpsPS/2 ALPS DualPoint TouchPad            id=16    [slave  pointer  (2)]
    eGalaxTouch Virtual Device for Multi        id=11 [slave  pointer  (2)]
    eGalaxTouch Virtual Device for Single       id=12    [slave  pointer  (2)]
    Virtual core keyboard                       id=3    [master keyboard (2)]
    Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    Video Bus                                   id=6    [slave  keyboard (3)]
    After executing the command:
    xinput set-int-prop 12 "Evdev Axis Calibration" 32 43 2039 52 1959
    still no calibration. For information, id=11 (Multi) is from testing with another monitor, normally I use the Touchscreen as Single Monitor. In a forum I have read to store the xinput-command in /etc/X11/Xsession.d/98x11-common_touchscreen , but still no calibration after reboot.

    4) In the file Guide/Linux_eGTouch_Release_Note.txt from the driver download there is a line with:
    -The calibration data is now store at /etc/eGTouchX.param
    However the file /etc/eGTouchX.param does not exist. I can create it, but I do not know the format of the calibration data to put in.

    5) I have found the file
    I did not found calibration data there.
    Does anyone know, is this file needed for calibration?

    Please help!
    Attached Images Attached Images
    Last edited by wasu; January 22nd, 2013 at 07:23 PM.

  2. #2
    Join Date
    Jan 2013

    Re: eGalaxTouch calibration does not work

    I have now installed Ubuntu 12.10 because I have read this has better touchscreen support than 12.04. At 12.10 no additional driver is needed but the axis are inverted. I could not manage to invert the axis. Here is the new post with the new problem:


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts