BTW let me know if you start experiencing WiFi issues.. Maybe it's something with the refind stuff. The only thing that I haven't been able to fix yet. It must be interference from something inside the MacBook. In OS X and Windows I get 50 MBit/s+, in Linux its around 5Mbit/s - 20MBit/s, lots of packet loss etc. Neither the internal nor an external USB WiFi adapter work.

But on the other hand I've also tried the USB WiFi with an extension cord, so it shouldn't be interference. Also I've tried different APs etc. Truly a mystery.

Lately I've been thinking I guess it could be that some component X is on which is interfering with WiFi and/or USB, but don't know. I mean some component that is turned on in Linux but not in Win or OS X. And oh yes, I always have Bluetooth disabled too.

Quote Originally Posted by freeaks View Post
i finally succeed in getting the intel driver running
now lspci report my two vga chips and X is running fine with i915.
i still run ubuntu only. the solution was to use refind (on esp) instead of grub.
so i have a 200mb fat32 partition with refind, a directory "ubuntu" where i've put my kernel, initrd and a config file like this:
cat /media/EFI/ubuntu/refind_linux.conf 
"Boot using standard options" "root=UUID=<uuid string> ro quiet splash $vt_handoff"
"Boot using minimal options" "root=UUID=<uuid string> ro" 
"Boot to shell" "root=UUID=<uuid string> ro text"
"Boot using recovery options" "root=UUID=<uuid string> ro recovery nomodeset"
installed raring daily iso, ran ubiquity with -b switch to prevent grub from being installed as explained in garalndg's guide here : http://linuxmacbookproretina.blogspo...cbook-pro.html

it seems to me grub was doing something that prevent i915 and vgawitcheroo to be used.