Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: does iwlwifi handle n mode now ?

  1. #1
    Join Date
    Apr 2008
    Beans
    109

    does iwlwifi handle n mode now ?

    hi,

    it was not the case until recently, so does the iwlwifi driver work now flawlessly with wifi n access points ?

    Thanks !

  2. #2
    Join Date
    Apr 2008
    Beans
    109

    Re: does iwlwifi handle n mode now ?

    http://lkml.indiana.edu/hypermail/li...1.2/01599.html

    seems to contain some improvements about iwlwifi.

  3. #3
    Join Date
    Jan 2007
    Location
    Kentucky, USA
    Beans
    1,684
    Distro
    Ubuntu Development Release

    Re: does iwlwifi handle n mode now ?

    I was using wireless N with 12.10 and iwlwifi. I have a Centrino Wireless-N 2230 card. What does
    Code:
    sudo lshw -C net
    say?

  4. #4
    Join Date
    Apr 2008
    Beans
    109

    Re: does iwlwifi handle n mode now ?

    Code:
    produit: Centrino Advanced-N 6205 [Taylor Peak]
           fabriquant: Intel Corporation
           identifiant matériel: 0
           information bus: pci@0000:03:00.0
           nom logique: wlan2
           version: 34
           numéro de série: xxx
           bits: 64 bits
           horloge: 33MHz
           fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=iwlwifi driverversion=3.8.0-1-generic firmware=18.168.6.1 ip=192.168.1.10 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
           ressources: irq:47 mémoire:f1400000-f1401fff
    I can connect in N mode, but I get many errors in iwconfig, and the connection speed often slow down to 1 Mb/s. Avoiding N mode in my wireless router makes my connection by far better (even with a max speed slightly inferior) especially when the signal is weak.
    Last edited by ft_; January 25th, 2013 at 11:37 PM.

  5. #5
    Join Date
    Jan 2007
    Location
    Kentucky, USA
    Beans
    1,684
    Distro
    Ubuntu Development Release

    Re: does iwlwifi handle n mode now ?

    I ran across this http://askubuntu.com/questions/19026...-do-i-debug-it

    It seems to be a random iwlwifi bug. Maybe it will help?

  6. #6
    Join Date
    Sep 2008
    Location
    Windsor,CT
    Beans
    540
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: does iwlwifi handle n mode now ?

    Code:
    $ sudo lspci -vv
    
    .....
    
    03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 (rev 34)
    	Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN
    	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    	Latency: 0, Cache Line Size: 64 bytes
    	Interrupt: pin A routed to IRQ 55
    	Region 0: Memory at f3900000 (64-bit, non-prefetchable) [size=8K]
    	Capabilities: [c8] Power Management version 3
    		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
    		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    	Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    		Address: 00000000fee003b8  Data: 0000
    	Capabilities: [e0] Express (v1) Endpoint, MSI 00
    		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 unlimited
    			ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset+
    		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
    			RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+ FLReset-
    			MaxPayload 128 bytes, MaxReadReq 128 bytes
    		DevSta:	CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
    		LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <4us, L1 <32us
    			ClockPM+ Surprise- LLActRep- BwNot-
    		LnkCtl:	ASPM L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
    			ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
    		LnkSta:	Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    	Capabilities: [100 v1] Advanced Error Reporting
    		UESta:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    		UEMsk:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    		UESvrt:	DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
    		CESta:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
    		CEMsk:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
    		AERCap:	First Error Pointer: 00, GenCap- CGenEn- ChkCap- ChkEn-
    	Capabilities: [140 v1] Device Serial Number 10-0b-a9-ff-ff-8d-d9-b8
    	Kernel driver in use: iwlwifi
    	Kernel modules: iwlwifi
    
    
    .....
    I have the same model on my thinkpad and I get great wireless-N speed (between 8-10MB/s internally pc to pc, both wireless n, 3-5Mb/s from internet). Heres a peak transfer graph from my router for today (I was rsyncing centos so I couldnt hit peak today internally on my network):



    I dont know if this is fast compared to other people's setup but its the fastest ive ever achieved on my setup (dual band n router). The only way I can get these speeds is by custom tweaking the options for the wifi modules on all my Linux pc's, otherwise its not achievable from my testing.

    Here is basically what I do:

    Code:
    $ modinfo iwlwifi
    filename:       /lib/modules/3.2.0-36-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
    alias:          iwlagn
    license:        GPL
    author:         Copyright(c) 2003-2011 Intel Corporation <ilw@linux.intel.com>
    version:        in-tree:
    description:    Intel(R) Wireless WiFi Link AGN driver for Linux
    firmware:       iwlwifi-5150-2.ucode
    .... [removed]
    srcversion:     C9C876E115EE7BFFAFB2FA7
    alias:          pci:v00008086d00000892sv*sd00000466bc*sc*i*
    .... [removed]
    depends:        mac80211,cfg80211
    intree:         Y
    vermagic:       3.2.0-36-generic SMP mod_unload modversions 
    parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
    parm:           queues_num:number of hw queues. (int)
    parm:           11n_disable:disable 11n functionality (int)
    parm:           amsdu_size_8K:enable 8K amsdu size (int)
    parm:           fw_restart:restart firmware in case of error (int)
    parm:           ucode_alternative:specify ucode alternative to use from ucode file (int)
    parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
    parm:           bt_ch_inhibition:Enable BT channel inhibition (default: enable) (bool)
    parm:           plcp_check:Check plcp health (default: 1 [enabled]) (bool)
    parm:           ack_check:Check ack health (default: 0 [disabled]) (bool)
    parm:           wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable, 2=enable (default: 0) (int)
    parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
    parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking (default: 0) (int)
    parm:           power_save:enable WiFi power management (default: disable) (bool)
    parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)
    parm:           auto_agg:enable agg w/o check traffic load (default: enable) (bool)
    parm:           no_sleep_autoadjust:don't automatically adjust sleep level according to maximum network latency (default: true) (bool)
    Ok so the most important part is the depends (other modules this module uses which may have more options) and the parameters (parm) each module supports.

    Using these parameters I create a file (/etc/modprobe.d/iwlwifi.conf) for modprobe and specify values for the options I want to modify for each module as follows:

    Code:
    options cfg80211 cfg80211_disable_40mhz_24ghz=0
    options iwlwifi fw_restart=1 bt_ch_inhibition=1 bt_coex_active=1 swcrypto=1
    Note that even though some of the options I set are listed as default in the module, I still set them explicitly to make sure. So router config/signal issues aside, tweaking your settings like this helps a hell of a lot. Be sure to reboot for those settings to take effect.

    Hope that helps.

  7. #7
    Join Date
    Feb 2008
    Location
    Oblivion
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: does iwlwifi handle n mode now ?

    Does this actually refer to a testing 13.04 install? You don't mention. If not, I will move to the appropriate sub-forum.

  8. #8
    Join Date
    May 2007
    Location
    Vermont
    Beans
    869
    Distro
    Ubuntu

    Re: does iwlwifi handle n mode now ?

    its always handled N mode fine for me, never had any problems.
    Desktop: Windows 8 x64 | Intel Core i5-2500 | 16 GB DDR3 1333 | ATI 6950 2gb | 64gb Vertex 2/320gb/750gb/1tb hdd
    Laptop: System76 Lemur Ultra | Xubuntu 13.04 x64 | 2.5Ghz Intel Core i5-3210m | 8GB DDR31600 | Intel HD4000 | 500GB 7200rpm hybrid hdd

  9. #9
    Join Date
    Apr 2008
    Beans
    109

    Re: does iwlwifi handle n mode now ?

    I noticied that the two numbers in bold are quite big with N mode and rather low with BG mode :

    Code:
    wlan2     IEEE 802.11abgn  ESSID:"my-AP"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: <mac>  
              Bit Rate=5.5 Mb/s   Tx-Power=15 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:on
              Link Quality=38/70  Signal level=-72 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:HERE  Invalid misc:HERE   Missed beacon:0

  10. #10
    Join Date
    Mar 2006
    Beans
    4,405
    Distro
    Ubuntu Development Release

    Re: does iwlwifi handle n mode now ?

    @ ju2wheels What are you using to get that neat networking display ?
    if it ain't broke you haven't tweaked it enough

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •