I have a UEFI motherboard (Gigabyte GA Z77MX-D3H) and a 120GB SSD and 2TB HDD.

Here is my current config:
sda 120GB SSD
sda1 ntfs 100MB Windows boot partition
sda2 ntfs 70GB Windows partition
sda3 ext4 40GB Xubuntu / partition
sdb 2TB HDD
sdb1 ntfs 1500GB Storage partition
sdb2 swap 10GB Linux-swap
sdb3 ext2 500MB Xubuntu /boot partition
sdb4 ext4 300GB Xubuntu /home partition
Bootloader installed to sdb in Xubuntu installer

However, I cannot boot Xubuntu. Only the windows BCD bootloader ever appears. Even leaving default option and installing bootloader to sda doesn't work. Its always the Windows bootloader appearing.

I have tried booting from the 2TB HDD where I expect the MBR for GRUB2 will be installed from the installer but it just goes on to the Windows bootloader as if it couldn't find GRUB.

I have tried adding Xubuntu to the Windows BCD to chainload with EasyBCD but it just reverts straight to Grub4Dos prompt.

I think my motherboard being UEFI is relevant somewhere. I am unsure of what UEFI is in comparison to BIOS.



What configuration do I take to get this dual-boot up and running? I would prefer Xubuntu OS to be on the SSD and /home to be on the HDD.

Thanks