I have a dualboot, Windows 8, and Ubuntu 12.04 (64 Bit), desktop computer. Everything used to work fine (other than a few minor transparency glitches) until one time when I shut down my computer. The next day, It would not start up into the login screen. It will show the logo with the dots, but then the screen will go black with a blinking cursor that no commands work with. I've tried to use all the commands I could think of (ctrl-alt-delete, esc, bksp. ctrl-alt-F1 through F12. Practically every key on the keyboard). Before I shut down my computer, I installed a few packages for webcams (one of which did not work and I uninstalled), and I updated my packages. When I go into the safemode options screen, I've tried to connect to the network and fix packages, and that worked (other than a few of them which always wouldn't update even before Ubuntu stopped working). But even still, If I do SafeX startup, it inits some processes, and then does the same thing; a blank, blinking cursor. When I do normal startup from the safemode options, it also inits some things, the last being ALSA sound manager, and then tthe same thing happenes. But when I press the power, it will show processed being terminated and will shut down. The CMD option in the Safezone options DOES work. I think all the commands work there. Please help, and thanks in advance. SPECS:

Graphics card: NVIDIA gt 440 1Gb GDDR5
X Settings: I have NVIDIA X server installed with one of the recommended drivers. 1280x1024 @75hz
CPU: Intel i3 2120 2nd Generation, 3.3 Ghz, 2 cores, 4 multitasking units or something
Motherboard: some modern gigybyte one