Ah, adding the dns-nameservers line did the trick.

Now the issue is that I can't access the server from my Windows machines through the GUI. Navigating to \\192.168.1.104 in Explorer gives me a "Windows cannot access 192.168.1.104" error. That would suggest that the server isn't allowing connections from other machines, but how do I go about changing that in Ubuntu Server (note that I don't have a firewall enabled on the server yet, so that's not the issue)?