I was pretty optimistic after reading the post regarding blacklisting the Intel chip, however unfortunately it didn't make any difference in terms of Xruns (although it did remove the option in qjackctl for the device, so I can assume it did actually disable it!).

In addition to running my script from earlier, I've also followed the instructions at http://darksound.co.uk/?p=256 to disable some further features. I also removed pretty much everything that autostarts in the "Session and Startup" section of the Ubuntu Studio settings.

I'm still getting these Xruns at regular intervals. It doesn't sound at all like the machine is 'struggling' at any point before or after the Xruns - no stuttering or popping (until the Xrun itself!).

The only thing I can think of now, is the USB cable I'm using is pretty old. I've read somewhere though that I shouldn't be able to select 96kHz if the cable is incompatible. I think this is desperation speaking however!

One other thing I noticed - if I don't manually disable networking through the GUI before my running my script, my WiFi connection persists for some reason. I've been making sure to manually disable it each time before running the script.

Thanks again for the support. I've still not tried to install Ubuntu Studio on my desktop, however am going to do so soon. Would rather be able to use it on my laptop however.

I've not yet attempted to troubleshoot the Xrun messages in qjackctl, however this may be another option for me to investigate.