Hello. Sorry in advance for my bad grammer. I am dyslectic.

Today I wanted to install Steam on my Ubuntu computer after reading that the beta was out. I installed it and everything worked I wast just going to upgrade the drivers for my computer cus I was following the steps listed on the Ubuntu website

"AMD/ATI Graphics

1 Enable the pre-released updates. You can enable this repository by opening Ubuntu Software Center, selecting Edit | Software sources... and then enabling the Pre-released updates option on the Updates tab.

2 Update your repository to the latest version in the Update Manager.

3 Remove the currently installed drivers.

4 In 12.04, launch the Additional Hardware Drivers dialog from System Settings. In 12.10, launch Software Properties, then click on the Additional Drivers tab in the Software Sources menu.

5 Install the newest fglrx-experimental-X driver."

Now the only thing I know that I did wrong was hat I removed the currently installed drivers before updating my repository. Anyways after updating my repository I was going to install the drivers like step 4 tells me. I open my system settings and click on Additional drivers. It checks for drivers and then nothing. The program doesn't even start up. I tried restarting my computer but it still doesn't want to start.

I tried removing it via the Software center and then installing it again. But that didn't help ether

It really sucks cus I have no additional drivers not and my system is running slower because of it.

Anyone here who knows a way to fix it? maybe installing the drivers via the terminal or something.

I use a emachines E730G the stickers on it says intel CORE i3 and ATI mobility Radeon HD 5470 Graphics 512 MB. I don't really know a lot about hardware so don't ask anymore about it