Results 1 to 3 of 3

Thread: stop dbl clk shell script

  1. #1
    Join Date
    Mar 2009
    Beans
    85

    stop dbl clk shell script

    I would like to try to stop myself from accidentally dbl click shell scripts that may be in folders. Is there a way to disable "allow this file to run" for shell scripts. If I want to run a shell script, I should be in terminal 99% of the time, not in the desktop gui.

  2. #2
    Join Date
    Dec 2009
    Location
    germany
    Beans
    1,020
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: stop dbl clk shell script

    Quote Originally Posted by pjmlmas View Post
    I would like to try to stop myself from accidentally dbl click shell scripts that may be in folders. Is there a way to disable "allow this file to run" for shell scripts. If I want to run a shell script, I should be in terminal 99% of the time, not in the desktop gui.
    hi
    just ain't give your script the x-bit. then you have to start it in a terminal with:

    bash your_script

    cheers
    "What is the robbing of a bank compared to the FOUNDING of a bank?" Berthold Brecht

  3. #3
    Join Date
    Jun 2006
    Location
    Brisbane Australia
    Beans
    713

    Re: stop dbl clk shell script

    Quote Originally Posted by pjmlmas View Post
    I would like to try to stop myself from accidentally dbl click shell scripts that may be in folders. Is there a way to disable "allow this file to run" for shell scripts. If I want to run a shell script, I should be in terminal 99% of the time, not in the desktop gui.
    That's an option in Nautilus/Preferences/Behaviour/.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •