I am having trouble setting permissions of a few disks I added to my ubuntu server. I got the disks working fine and mounting on boot-up. The disks boot and mount into the location /media/TV for one, and /media/Movies for another drive. I have them both shared via SMB and the server is shared via SSH so I can connect to the drive via SMB or SSH.

I can go to the terminal on my Mac, connect to the server via ssh, and enter the command

sudo cp /home/myhome/stuff /media/TV/stuff
and it will copy over the content to my TV drive with no problem. The minute I try and open up the SSH via an sftp program, cyberduck is what I am using, or Filezilla is an alternative. Neither work. I get an error:
"Failure (SSH_FX_FAILURE: An error occurred, but no specific error code exists to describe the failure.)."
I then tried to copy over the files by connecting to it from Finder on my Mac via smb://myUbuntuServer

I tried to copy some files over that were on my mac to this /media/TV SMB share and it feeds me the error:

"Items can’t be copied to “Ubuntu-TV” because you don’t have permission to read them."
When I set up the SMB share... I specifically called the folder Ubuntu-TV, (pointing straight to /media/TV) here is my /etc/samba/smb.conf file

path =/media/TV
available = yes
valid users = myUserAccount
read only = no
browsable = yes
public = yes
writable = yes

I've tried

sudo chmod -R 775 /media/TV

sudo chmod -R 777 /media/TV

What am I doing wrong here!?