Results 1 to 3 of 3

Thread: 12.04 un-clone mac address

  1. #1
    Join Date
    Feb 2009
    Newark, DE
    Ubuntu 8.10 Intrepid Ibex

    12.04 un-clone mac address

    How do I un-clone the MAC address on my NIC? This is driving me NUTS!

    Using network manager I cloned a mac address (to try and sort out some network issues). I've since removed the entry in 'Cloned MAC address' and am left with two Wired connections:

    Auto Ethernet, which still contains the cloned MAC
    Auto eth0, which contains the device MAC

    eth0 is not listed as an option to connect in nm-applet.
    deleting 'Auto Ethernet' does not persist (restarting networking readds it).

    ifconfig lists eth1 with the cloned MAC address.

    I tried stopping network-manager ('service network-manager stop').
    ifconfig -a still lists eth1 with the cloned MAC.
    restarting networking ('/etc/init.d/networking restart') was no help (eth1 exists, no eth0).
    Removing the module (r8169) then reinserting it, bring back eth1 (no eth0)

    70-persistent-net.rules contains a line that remaps eth0 to eth1 and sets up the cloned address:

    # PCI device 0x10ec:/sys/devices/pci0000:00/0000:00:1e.0/0000:07:01.0 (r8169)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:00:00:00:00:00", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

    If I remove the module, delete the line, and then re-add the module, udev re-adds the line.

    How do I un-clone the MAC address and get back to just using the one from the device (and preferably get back eth0)?

  2. #2
    Join Date
    Dec 2012

    Re: 12.04 un-clone mac address

    Have you solved this problem?

  3. #3
    Join Date
    Jul 2008
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 un-clone mac address

    I am having this same problem. I cloned a mac address so I could get matlab to run on my new machine, which worked for a while. Yesterday I tried to run Matlab and it didn't work because it didn't recognize my MAC address. I looked at the network manager app and it was using the "Auto Ethernet" connection, and won't let me use my manually configured connection. Further, it shows that the hardware address IS the cloned mac address, and won't let me change it to anything else.

    I didn't think it was possible to change the physical MAC address, so this is really confusing for me. How did the cloned address permanently take the place of the hardware mac address? How can I undo this?

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts